Home AMX General Discussion

Why Am I loosing my IP connection

davegrovdavegrov Junior MemberPosts: 114
I am running an NXI-200o with the latest firmware updates. Every time I try to log on via Netlinx Studio it times out. If I reboot the controller (cycling power) I have no problem connecting. When I attempt to listen in Studio under Master Communications the lsiten mode sees the processor. What am I doing wrong or what settings do I need to range.

Comments

  • HedbergHedberg Junior Member Posts: 671
    This is what I do:

    Connect to the master through the RS232 program port, go to diagnostics, to Network Addresses, and select "Get IP Information". Then set the IP address and Subnet Mask as appropriate, hit "set ip information" and reboot.

    AT this point, you will be able to connect to your master _IF_

    1. you have the correct physical connection. If you are connecting directly from your PC to the master, you will need a crossover cable -- neither the master nor the NIC card (as far as I know) will work correctly with a cable of the wrong termination type. If you are using a switch/router, make sure that the master and NIC are both connected to LAN terminals and not to an "uplink" or WAN connection. If you are using a switch, you can probably use either straight or crossover cables as most of these devices (DLink, NetGear, Linksys) will automatically accomodate themselves. Best, though, to verify your cable integrity and use only straight cables with switches and crossovers for direct connections and switch to switch connections.

    2. Your NIC connection on your PC must be properly configured with an IP address and subnet mask that is appropriate -- that is, your PC and Netlinx master have to be on the same subnet. If your master, for example, is 192.168.1.99 with 255.255.255.0, then your PC must be 192.168.1.n with 255.255.255.0. If one of them is 192.168.1.n and the other is 192.168.0.n, you are likely to be in trouble. Make sure that if your NIC is expecting DHCP that your DHCP server is giving you an IP address to your computer that will work with your master. If you want to see exactly how your NIC card is configured (IP-wise) bring up a "DOS" window (hold down the funny windows key and hit the r key, type in "cmd" where it says "OPEN" and hit <cr> and type in "ipconfig/all" You will get a list of all your IP configurations (duh).

    You may need to change settings for your NIC in your "Network Connections" dialog depending on whether or not you have a DHCP server in the network.
    Go to control panel, select network connections, right click the NIC (probably listed as LAN) and select properties, select "internet protocol" and select properties and there you are.

    I hope this helps and I apologize if I'm covering stuff you already understand.

    Harold
  • DHawthorneDHawthorne Junior Member Posts: 4,584
    My experience is that static IP's are far more stable than dynamic from the network DHCP server. The fact you are connecting at all suggests your settings are OK. After a fresh reboot, I would go immediately into the Network settings, then do a get and save on both the network and DNS sections. Then set the IP to static, editing the value that is there already if necessary (it's a good idea to put static IP's outsie the range the DHCP server will assign - most default to using addresses over 100, so put the NetLinx master below that).

    If you are already using a static IP, or that doesn't improve anything, look to the code running on the master. If it gets sufficiently bogged down in the message queue, it can fall offline. This could be caused by other network devices going offline, or by too-frequent feedback updates.
  • ipssheldonipssheldon Registered User Posts: 106
    I don't know if this is the same issue, but I had a problem where I could connect to a master via IP, do anything that I wanted, but as soon as I downloaded a program and the master rebooted, then I had to ping the master before Studio would reconnect. I found that the problem was in my Zonelabs firewall that was not allowing a protocol in my trusted zone. I think it was ICMP, although I may be mistaken. In any case, the solution was to tweak my firewall settings and then everything started working correctly. It took me a long time to find this out and even then it was a chance occurrence that I found it. You might look at your firewall on your laptop or PC that you are trying to connect with.

    Just a thought.

    Sheldon Samuels
    IPS Resources LLC
Sign In or Register to comment.