Home AMX General Discussion

Ethernet problems

jswilsonjswilson Junior MemberPosts: 17
I am currently trying to hookup an NXT-CV10 to an NI-3000 via a crossover ethernet cable. In the touchpanel, I have set the DHCP/Static field to Static and assigned it a static IP. The Master Connection is set to Ethernet and the Mode is URL, and I have set the Master IP to the IP address I got from the NetLinx Diagnostics program. The panel IP is 10.176.14.199 and the master is 10.176.14.202.

I have verified that the cable is in fact a crossover; I was able to successfully access the master from my PC using the same cable. However, when I plug in the cable, I never see any LEDs blink, and I can never get the touch panel to appear as a device in NetLinx Studio or the Diagnostics program ( I am simultaneously connected to the master via RS-232 to my PC ).

Is there something basic I'm missing here? I am still new to this, so I want to make sure I'm passing any kind of "idiot test" you guys might know of. Thanks for any help you can offer.

Comments

  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    Need a switch

    You?re settings sound fine. However, I?ve never wired it the way you explained and if I understand you correctly, I don?t think it will work.

    The standard route to take is to plug in your NI master and your touch panel into a switch that is on the same network as your PC. I think you can pick up an 8 port Linksys switch for under $75.
  • Rod NRod N Junior Member Posts: 28
    Put in a hub..get rid of the crossover. For the small cost of the hub and cables you'll save a lot of grief.
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    I?d go with a switch over a hub. There isn?t much cost difference and the performance of your network is worth the extra dollars. Hubs spray data everywhere. Switches have the intelligence to only send data where it needs to go. But if you are in a pinch and have an old hub collecting dust then I?m sure it will suffice.
  • GSLogicGSLogic Original Member Posts: 562
    I've used a crossover cable if the ethernet connection wasn't being used in the system.

    I have ran into trouble a couple times and this always seems to works.
    Try setting your computer to have a static IP 1 digit below the NI.
    NI = 192.168.1.11
    PC = 192.168.1.10
  • dchristodchristo Junior Member Posts: 177
    jswilson wrote:
    The panel IP is 10.176.14.199 and the master is 10.176.14.202.

    What's your subnet mask?

    --
  • GSLogicGSLogic Original Member Posts: 562
    dchristo wrote:
    What's your subnet mask?

    --


    255.255.255.0
  • NMarkRobertsNMarkRoberts Junior Member Posts: 455
    jswilson wrote:
    However, when I plug in the cable, I never see any LEDs blink

    Doesn't that mean you have a problem with the physical connection rather than the IP addressing?

    When I disconnect the network cable, both LEDs are dark.

    When I have good IP comms, I see an orange and a yellowygreen LED lit up on my NI700.

    When I set a random IP address and reboot, both are still on.
  • vincenvincen Junior Member Posts: 526
    Well green and orange LED on Ethernet port just means physical connection is OK and data is transmitted, it doesn't mean it communicates efficiently.

    Just a reminder: cross-over cable has never been something official in Ethernet world, it works often but not always as you are never supposed to link two Ethernet devices just like that, it must pass through at leat an hub, or better a switch ;)

    Vinc
  • jswilsonjswilson Junior Member Posts: 17
    Success!

    I put in a switch, now it works great! Thank you so much for your swift and accurate responses.
Sign In or Register to comment.