Home AMXForums Archive Threads Residential Forum

No Feedback From Lutron

ClingpeachClingpeach Junior MemberPosts: 156
There was a 29 hour power outage inp the Westchester, Ny area last week. All Lutron keypads are working fine switching on the correct switches and graphic eyes with feedback on the Lutron keypads. All AMX panels are switching off and on the correct lights and switches.
PROBLEM: There is NO FEEDBACK ON THE AMX PANELS.
Have rebooted the Lutron, the AMX etc.
Any help??

Comments

  • viningvining X Member Posts: 4,368
    You could use this in the HomeWorks Online_Event:
               send_string dvHWI, "'DLMON',13"//enable dimmer monitoring
    	  send_string dvHWI, "'KBMON',13"//enable keypad monitoring
    	  send_string dvHWI, "'KLMON',13"//enable keypad led monitoring
    	  send_string dvHWI, "'VMD',13"  //disable vaction mode
    	  send_string dvHWI, "'VMR',13"  //start recording vacation mode
    
    (Not for AMX module unless sent direct to HWI not virtual.)

    2nd the serial device driver for the port connected to AMX probably wasn't set up properly for the desired feedback needed so when the HomeWorks processor was affectively power cycled it rebooted back to default. Possibly with your generator it hasn't been an issue before.

    If your data_event has code similar to that shown above you can just reboot the AMX and your feedback should return.
  • Chip MoodyChip Moody Junior Member Posts: 727
    If this uses a GRX-232 interface, you might want to double-check and/or toggle the dipswitches on it that are responsible for feedback.

    - Chip
  • ClingpeachClingpeach Junior Member Posts: 156
    This is the ORIGINAL HOMEWORKS system. Ive had power outages before its never happened. I hope to get in touch with the programmer soon.
  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 548
    Clingpeach wrote:
    This is the ORIGINAL HOMEWORKS system. Ive had power outages before its never happened. I hope to get in touch with the programmer soon.


    Homeworks or Interactive? If its an Interactive processor and the baud rate on the rs-233 port is something other than default, cycling the power on the Lutron processor will reset it to its default unless there is a "driver" programmed to that communication port. Default is hardware flow control (CTS and RTS enabled) at 38.4k (I think)
  • ClingpeachClingpeach Junior Member Posts: 156
    its ORIGINAL homeworks..i think the first one..never given me a days problem.and ive had it for 12 years or so...problem is i have so much tied into it..oh well the programmer only gets back next week..
  • DHawthorneDHawthorne Junior Member Posts: 4,584
    Lutron hasn't changed the protocol from the original Homeworks to Interactive, except to add new features. The monitoring commands should still work.
  • ClingpeachClingpeach Junior Member Posts: 156
    I have been on the phone with Lutron tech support. He had me hyperterminal into the Lutron system and i got feedback.
    Is it possible that the power storm did something that requires the program to be downloaded to my Netlinx processor in order to regain feedback to the AMX panel??
  • alexanboalexanbo Junior Member Posts: 282
    If you're talking old school Homeworks that's programmed through the DOS type utility here's the RS-232 manual. It says something about flipping the third dip switch on the processor to up. Doesn't really look like you can change the baud from the default. Now there is in actuality a Homeworks system older then this version, but I don't believe you could integrate with it because it was programmed from the switches etc...
  • ClingpeachClingpeach Junior Member Posts: 156
    The lutron tech came today. The 3rd dipswitch is on. We hyperterminaled into Lutron it is gving feedback. The Lutron port on the Netlinx processor getting rx and tx commands..
    Still waiting on the programmer to get back from vacation. This is going to be interesting
  • alexanboalexanbo Junior Member Posts: 282
    So in diagnostics you can see the correct strings coming in the port? Almost sounds like perhaps the addresses in the AMX program for the Lutron keypads got lost. If you have the source code it might be worthwhile reloading that. Is it a Netlinx processor or an Axcent3 type procesor?
  • ClingpeachClingpeach Junior Member Posts: 156
    checking the incoming data and comparing it to what is in code to make
    sense as to what is happening. It appears as though the data coming
    back is correct but not showing the right info for the LED keypad
    status... (level status is fine changed a global parsing character to
    match what has changed from Lutron
Sign In or Register to comment.