Home AMX User Forum AMXForums Archive Threads AMX Hardware MAX by AMX

Keyboard in UI modules

adysadys Junior MemberPosts: 395
As mention here http://www.amxforums.com/showthread.php?t=2537

the string that are coming from the panel is coming only on port 1 system 1.

I change the code to support my TP ports (40) and system 0, but I get nothing from the panel - the keyboard is not working...

Any limit for the port?
Any tip how to solve that?

thanks

Ady.

Comments

  • mpullinmpullin Obvious Troll Account, Marked for Deletion Posts: 949
    I have found that the MAX UI module only works correctly if the channels/addresses are all set to port 1. That's just the way it was written, port 1 is hard coded into it at some point.

    If you have other pages in your system you will want to do a find/replace to change all channels/ports to a different number like 2 before adding the MAX pages in.
  • adysadys Junior Member Posts: 395
    that can't be done now...

    I have 10 systems with the appropriate ports.
    Everything is working like magic, only the keyboard strings are making me problems.

    I don't mind working with port 1 only for the keyboard if I must.

    Dave wrote here about the hard coded, I found it and changed it but I still have problems
    http://www.amxforums.com/showthread.php?t=2537

    But does keyboard strings must be on port 1? (not only for MAX)


    update:

    I moved back all keyboard buttons to port 1
    I change code to support system 0 instead of system 1


    Everything is working, thanks!

    Ady.
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    mpullin wrote:
    I have found that the MAX UI module only works correctly if the channels/addresses are all set to port 1. That's just the way it was written, port 1 is hard coded into it at some point.

    If you have other pages in your system you will want to do a find/replace to change all channels/ports to a different number like 2 before adding the MAX pages in.

    Not true - I have a large system with a lot of panels, all running on port 13. String outputs from a panel always come in on port one, but that is a panel issue, and the MAX UI module allows for this. It's the system number in the module that was mistakenly hard coded ... you have no choice about using port 1 for the strings.
  • adysadys Junior Member Posts: 395
    DHawthorne wrote:
    Not true - I have a large system with a lot of panels, all running on port 13. String outputs from a panel always come in on port one, but that is a panel issue, and the MAX UI module allows for this. It's the system number in the module that was mistakenly hard coded ... you have no choice about using port 1 for the strings.


    Dave, can you please tell what is the exactly code that you are runing to solve the offline zone issue?

    I have lot of troubles with that offline online issue...


    Thanks

    Ady.
  • mpullinmpullin Obvious Troll Account, Marked for Deletion Posts: 949
    DHawthorne wrote:
    Not true - I have a large system with a lot of panels, all running on port 13.
    Must have been fixed since I last put a MAX in... which admittingly was a while ago...
Sign In or Register to comment.