Home NetLinx Studio

Netlinx Studio v2.6 Build 191 Review ? The good the bad and the ugly.

Joe HebertJoe Hebert Junior MemberPosts: 2,159
The Good

We can now edit TCP/IP settings for Master Communications without having the entry duplicated first. :):)

There is a new set of clock manager functions with a CLKMGR_ prefix. :) I didn?t see the new functions mentioned anywhere, just happened to stumble across them while looking through the help file.

We now get tool tips for built in Netlinx functions. As jjames mentioned in an earlier thread the parameters for the functions show up as generic A,B,C, etc. The new clock manger functions added to Netlinx.axi have descriptive parameters. Hopefully the other DEFINE_LIBRARY_FUNCTIONs in Netlinx.axi will follow suit in the future so that the tool tips become useful.


The Bad
What?s New wrote:
BUG FIX - The problem with truncated strings/unpredictable messages being displayed in the Notification and Diagnostic panes has been corrected. This was occurring when a $00 value was imbedding in the string being sent/received from a device.
Not true, at least on my system. This code:
DEFINE_DEVICE

dvTP = 10001:1:0

DEFINE_EVENT

BUTTON_EVENT[dvTP,1] {

   PUSH: {
      SEND_STRING 0, "'abc',0,'def'"
      SEND_STRING 0, "'ghi',1,'jkl'"
   }

}

produces the following incorrect output when button 1 is pushed:
Line 1 (23:07:57):: abc
Line 2 (23:07:57):: ghi$01jkl


I was hoping to see Clear buttons added for the diag panes on the emulate/control dialog boxes; unfortunately we still have to close emulate/control first before we can clear.

I was also hoping we could edit the D:P:S settings for the Device Notifications entries but that request didn?t make the cut either.


The Ugly

I really miss not being able to enable ?Automatically Stamp File with Creation and Last Modified Date? without it mucking up code folding every time you do a save. This problem still exists in NS2 v2.6. :(:(

What?s New wrote:
FEATURE - Will only transfer TP4 files to G4 devices that have matching device types and resolutions. Therefore, the user will not be able to transfer an R-4 Remote type TP4 file to a MVP-7500 type panel.
Calling this a new feature sure puts a positive spin on a limitation. We used to be able to transfer and test an 800x480 TP file (like a CV7) into an 800x600 panel or bigger (like an MVP-8400 or CV12) and the file would run fine as it loaded in the top left hand corner. I was disappointed to see that the latest version of TP4 (v2.8 build 568) doesn?t allow us to do that anymore so I used NS2 to transfer the TP files instead. Now this new Feature in NS2 2.6 doesn?t allow us to do it anymore either.

I?m sure there is a valid reason why this had to be imposed but I?m not happy to see it. I guess it means I need to buy more test equipment...which isn?t a bad thing...expensive...but not bad...except for the expense part...and now I?m blabbering like an idiot so it?s time for me to make like a tree and split...

Anyone else have comments on Netlinx Studio V2.6 Build 191?

Comments

  • jazzwyldjazzwyld Registered User Posts: 199
    Joe I'm searching the "help" and I don't see the CLKMGR info. Where did you see that?
  • TonyAngeloTonyAngelo Code Monkey Posts: 315
    Joe Hebert wrote:
    The Ugly

    I really miss not being able to enable ?Automatically Stamp File with Creation and Last Modified Date? without it mucking up code folding every time you do a save. This problem still exists in NS2 v2.6. :(:(

    I agree, this is a very annoying "feature".
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    jazzwyld wrote:
    Joe I'm searching the "help" and I don't see the CLKMGR info. Where did you see that?
    You?re right; a search for clkmgr yields no results. I found them under:

    Contents - - > Reserved Identifiers - - > Keywords & Run-Time Library Functions.
  • Chip MoodyChip Moody Junior Member Posts: 727
    Yeah, this just makes for a new entry on the list of "Things that suck". :(
    Joe Hebert wrote:
    Calling this a new feature sure puts a positive spin on a limitation. We used to be able to transfer and test an 800x480 TP file (like a CV7) into an 800x600 panel or bigger (like an MVP-8400 or CV12) and the file would run fine as it loaded in the top left hand corner. I was disappointed to see that the latest version of TP4 (v2.8 build 568) doesn?t allow us to do that anymore so I used NS2 to transfer the TP files instead. Now this new Feature in NS2 2.6 doesn?t allow us to do it anymore either.
  • a_riot42a_riot42 AMX Wizard Posts: 1,619
    Chip Moody wrote:
    Yeah, this just makes for a new entry on the list of "Things that suck". :(


    Yes this is annoying as I was debugging a CV7 panel but only had an 8400, and everytime I had to convert the panel before uploading to check my work. This is a feature now?
  • Stephen BoltonStephen Bolton Junior Member Posts: 345
    Originally Posted by What?s New
    FEATURE - Will only transfer TP4 files to G4 devices that have matching device types and resolutions. Therefore, the user will not be able to transfer an R-4 Remote type TP4 file to a MVP-7500 type panel.


    In the past if we have had a panel misbehave or fail (particularly wireless issues), we have deployed a wired version with the mvp file loaded in it to get the client going.

    We don't always have the opportunity to save as different panel type on site...(Site guys carry File Transfer 2 only)
  • REBUILD_EVENTREBUILD_EVENT Junior Member Posts: 127
    Originally Posted by What?s New
    FEATURE - Will only transfer TP4 files to G4 devices that have matching device types and resolutions. Therefore, the user will not be able to transfer an R-4 Remote type TP4 file to a MVP-7500 type panel.


    In the past if we have had a panel misbehave or fail (particularly wireless issues), we have deployed a wired version with the mvp file loaded in it to get the client going.

    We don't always have the opportunity to save as different panel type on site...(Site guys carry File Transfer 2 only)


    AND it took 15 minutes with my old IBM Notebook (1.3Mhz, some 256MB of RAM) when there were like 30 or 40 popup pages...
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    Here?s an item to add to the ?good? list and it wasn't mentioned in the "What's New"

    The online tree in Netlinx Studio v2.6 Build 191 is by far MUCH better than v2.5 Build 163 and reports correctly from what I?ve seen so far.

    The online tree using version 2.5 was problematic for jobs with multiple systems as it showed multiple masters (device 0000) in systems and the NI-XXXX was missing from some systems. Using NS2 v2.6 the online tree looks perfect. :)
  • AMXJeffAMXJeff Senior Member Posts: 450
    Wow, actually a good comment!!!!!
    Joe Hebert wrote:
    Here?s an item to add to the ?good? list and it wasn't mentioned in the "What's New"

    The online tree in Netlinx Studio v2.6 Build 191 is by far MUCH better than v2.5 Build 163 and reports correctly from what I?ve seen so far.

    The online tree using version 2.5 was problematic for jobs with multiple systems as it showed multiple masters (device 0000) in systems and the NI-XXXX was missing from some systems. Using NS2 v2.6 the online tree looks perfect. :)
  • REBUILD_EVENTREBUILD_EVENT Junior Member Posts: 127
    AAAARRRRGHHH! I have an RS-232-Dongle, which is on COM10 in Windows, no idea how to change this.... have several devices below COM10 and even ports free (e.g. COM1)

    NS however doesn't let me choos COM10. I can only select devices between COM3 and COM9...

    does anyone know this? or have enough knowledge of windows to manually assign COM-Port numbers????


    [In netlinx diagnostic i CAN select com10 and it works, but not in file transfer 2]
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    AAAARRRRGHHH! I have an RS-232-Dongle, which is on COM10 in Windows, no idea how to change this.... have several devices below COM10 and even ports free (e.g. COM1)

    NS however doesn't let me choos COM10. I can only select devices between COM3 and COM9...

    does anyone know this? or have enough knowledge of windows to manually assign COM-Port numbers????


    [In netlinx diagnostic i CAN select com10 and it works, but not in file transfer 2]

    Generally, you can change the properties of dongles in Windows' device manager. I had to do that with mine - it wanted to default to COM 5, and I was able to force it to COM 4.
  • jjamesjjames Just another dude Posts: 2,903
    Finally!!!!!

    Wooooooooooo-hooooooooooooooooo! :D

    This used to be a problem, but seems not to be anymore. Whenever you would move an IR file, and double click on it to open it from the workspace, it would say it wasn't there. Well, before you couldn't go into the properties, and browse for the correct file location (okay, you could - but it wouldn't "save" or keep the new location.) The only option before was to remove the IR file (which included all device mapping), re-add it, then remap everything.

    Well, It now saves the location / properties when you browse for it. Saves ya from having to remove the file from the workspace and re-mapping everything.

    This REALLY makes me happy. :D
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    Okay, now this was weird...

    I opened an older project in the new NS2. All I did was do the 'check compiled version on master' thing. The Master's program matched the compiled version.

    I commented out a single line of code to disable something. Hit build active system, and got an error. After checking the error, I found that a device name (dvMSPAS16) had been changed to dvMSPAS 6 with a space between S and 6. I fixed this error and recompiled. I then found out that several instances of device names had been altered.

    To make sure I wasn't crazy, I opened a backup copy of the project on a laptop with an older version of NS2 on it and it looked fine.

    Has anyone seen any wierdness like this with the new Studio?
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    Nope, never had that one. How very strange.
  • JeffJeff Junior Member Posts: 374
    Joe Hebert wrote:
    Here?s an item to add to the ?good? list and it wasn't mentioned in the "What's New"

    The online tree in Netlinx Studio v2.6 Build 191 is by far MUCH better than v2.5 Build 163 and reports correctly from what I?ve seen so far.

    The online tree using version 2.5 was problematic for jobs with multiple systems as it showed multiple masters (device 0000) in systems and the NI-XXXX was missing from some systems. Using NS2 v2.6 the online tree looks perfect. :)

    I must admit I was a little disappointed when I tried to verify this. I've got a system with 17 masters in it right now. A lot of the previous issues have been fixed, like you mentioned, but I've still got a weird "Other Systems" system at the bottom of the list. If you click the +, it expands to show a bunch of AMX Masters that are on this same network but do NOT have their IP addresses in any URL list. At this exact moment, these masters don't even have code loaded to 'em yet (my project for today). It also shows several of the masters that are correctly placed in the list above. Systems 3, 4, 5, 54, 55, 56, 57, and 58 all show up in both places. This causes all of the counts at the bottom to be off (it says I've got 32 masters, which I don't)

    But yea, other than that, it seems to be MUCH better, which is nice. I might actually use the Online Tree again now.

    J
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    Jeff wrote:
    If you click the +, it expands to show a bunch of AMX Masters that are on this same network but do NOT have their IP addresses in any URL list.
    If you telnet into your main AMX Master and do a "route mode direct" and a "set udp bc rate" to 0, do those non URL list IPs disappear?
  • JeffJeff Junior Member Posts: 374
    My main master isn't talking directly to all 17 systems, because I have plans to be up in the 35-40 system range within the next 6 months. My understanding is i can't add 35 - 40 URLs to the URL list of my main master, so i have 10 URLs on it, and one of the URLs it is connected to has another 6.

    Switching to "route mode direct" made the other 6 rooms show up as systems that existed, but the online tree never populated them with any devices or masters, and remained stuck in refresh mode, so when I right clicked my only option was to "cancel refreshing online tree"

    Changing the udp bc rate doesn't seem to have made a difference at all.

    And no matter what, some masters are still showing up double.

    J
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    Jeff,

    Did you reboot the master after changing to route mode direct? Even with the previous version of NS2 my "other systems" disappear?
  • JeffJeff Junior Member Posts: 374
    rebooting kicked all of my non-direct systems out of communication with my main, but all it did was remove information about the other systems from the online tree. The systems themselves all appear to be there, but there is no + on the left to expand the system to see whats in it. Other Systems also includes all the nonURL list stuff
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    Hmmm, don?t know what else I can suggest. Sorry I couldn?t be of any help.
  • JeffJeff Junior Member Posts: 374
    No Prob. Like I said, its still MUCH better than it was. Now every problem involved shows up under the "other systems" tab, and the information under the systems actually shown is all correct. I'm VERY happy with that. I just wanted the record to reflect that it wasn't perfect yet.

    J
  • Joe HebertJoe Hebert Junior Member Posts: 2,159
    Roger that.
  • AuserAuser Junior Member Posts: 506
    FEATURE - Will only transfer TP4 files to G4 devices that have matching device types and resolutions. Therefore, the user will not be able to transfer an R-4 Remote type TP4 file to a MVP-7500 type panel.

    Aaaargggghhhh! This is driving me nuts and has wasted hours of my time and that of other staff.

    Has anybody discovered a downgrade procedure for NS/FileTransfer 2 which gets the old dll's installed so that you can send a 7500 file to an 8400, etc.?

    Whilst I'm sure there were reasons behind crippling this product, IMHO this was a terrible change and whoever made the decision was ignorant to the needs of the users.</rant>
  • AuserAuser Junior Member Posts: 506
    It appears after a bit of poking that the new "feature" is integral in the NS2 executable. I suppose I'll have to decide whether the other fixes are worth not downgrading to the previous version of Studio. :(
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    Okay, this is a small deal but it's still anoying. My NS studio seems to be forgetting its editor font settings. You'll start up the program and the whole look has changed.

    I can deal with this except for the fact that it chooses a pretty unreadable font when it decides to rearrange itself. Its been doing it on both my desktops but only once on my laptop.

    I'm reasonably sure noone is playing a prank on me since I'm the only one who uses the machines and it's password protected.
Sign In or Register to comment.