Home AMX User Forum AMX Technical Discussion

No SEND_LEVEL Across Systems

TurnipTruckTurnipTruck Junior MemberPosts: 1,485
Greetings,

I have a remote system that has three of my local G4 panels defined within it. When I try to do a SEND_LEVEL from the remote system to a G4 panel on my local system, I get nothing. Button feedback and varaiable text works fine though.

Any ideas?

Thanks.

Comments

  • DHawthorneDHawthorne Old Timer Posts: 4,584
    How high do your level numbers go? Multi-master systems use a virtual to represent devices on a remote master, so the 8 level limit applies. You will need to define your remote panel on the system sending the level, naturally, but also add a SET_VIRTUAL_LEVEL_COUNT to the ONLINE event of the panel.
  • TurnipTruckTurnipTruck Junior Member Posts: 1,485
    The level number was 61. Not because I have 61 levels, but due to the channel convention I use for this particular piece of equipment.

    I changed the level code to 1 and it now works, thank you very much.

    Is there any down side to setting the virtual level count higher?

    Thanks.
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    There is, but it's minor - it allocates memory on the master whether you are using the levels or not. That also goes for port and channel numbers, by the way. If you define something with port 50 and device 500, ports 1-49 get allocated if if not defined, and channels 1-499. The memory overhead is relatively small, but if you do a lot of that, it can create memory shortage issues.
Sign In or Register to comment.