RS-232

Thomas HayesThomas Hayes Junior MemberPosts: 1,164
Hello All
Here is a really cool problem that had me for several hours. The install was 4 projectors, lifts, screens, drapes, etc.(big for a school system) When I down loaded the program to test the system 2 of the 4 projectors worked. Like normal we tested that the Rx/Tx LEDS were coming for all 4. Checked the projector baud rate, etc- all ok. Went up to the projectors and removed the 9-pin cable, now is were it gets funky, the Rx/Tx LEDS still worked for the projector with the cable removed at one end Tested the cable for shorts-ok, rang cable to make sure we had the correct cable-ok. Ran a new cable to test- projectors both worked, but their existing cables tested good and the runs were less or just over 50'. Took a real good look at the 2 projectors that worked and the 2 that didn't. All were wired correctly but we noticed that the working projectors used 1-pr and the the non working were wired with 2-pr. Re-checked the colour code and pin out-ok. Only thing was that the installer had used a wire from the second pair for pin#5(gnd) and not the shield. Removed the wire and wired pin#5 to the shield-projector worked!! Some time back I remember reading an article that RS-232 distance had more to do with the cap. of the wire than the total length of cable. I've ran 4 connector before with no issues but the 2 pair at this distance was enough not to work. So even if a cable tests good it could still be bad.

Comments

  • TurnipTruckTurnipTruck Junior Member Posts: 1,485
    Distance limitations with RS-232 have most to do with noise immunity. As RS-232 is unbalanced, it is very succeptable to ground loops, much like hums in audio systems. Ground loop noise is the cause of most 232 failures. I have gone out to hundreds of feet with 232 at higher baud rates when there is no electrical ground at one end, such as with a laptop on battery. Once the laptop is plugged into a grounded power source, the communication will typically die.

    Cable capacitance has the same affect on RS-232 as it would on RS-422, etc. It really isn't an issue at typical cable lengths for our systems and at typical baud rates.

    The ideal 232 cable would be an individually shielded conductor for TXD and another for RXD. However, a shielded pair for both channels of the 232 is usually fine. I have heard stories of crosstalk between the RXD and TXD, but have never seen it myself. If it occurs, it's probably a symptom of a lack of termination at the devices.

    A Cat-5 twisted pair should never be used for RS-232. I have seen it done quite a bit and can result in intermittant operation, especially in places with potential sources of RFI.

    I use West Penn 452 for my RS-232 lines. It's cheap and small.
  • Thomas HayesThomas Hayes Junior Member Posts: 1,164
    The cap. issue article I read had to do more with the uart chipsets that RS-232 devices use. Yes, RS-232 is un-balanced and is open to noise issues. I'll see if I can find and post the article I saw, it might be able to explain the issue better than I. was just one of those very odd issues that you don't see often. Like you I have many runs well over the so-called max run distance of RS-232 that work fine. The ground loop issue would of likely still be there when I pulled the test cable, to help prevent such problems, we insist on same phase/ ground connections for all our installations. BTW thanks for the input, always welcomed. It
  • Jurgen SachsJurgen Sachs Junior Member Posts: 33
    I saw the crosstalk on some installations.
    If you use CAT5 for RS232 you should never use one twisted pair for RX and TX.
    In some installations it helped to do TX and GND on a twisted pair and RX and GND.
    If you have a long run and a CAT5, I would suggest to buy an RS422 to RS232 converter for the projector side and hook it up to the RS422 lines on the netlinx device.

    Then you should not have any crosstalk at all and you can have LONG runs :-)
  • Thomas HayesThomas Hayes Junior Member Posts: 1,164
    http://hydraulicslab.ucsd.edu/RS232/rs232.htm is an excellant article that explains the cap. issue with cable.
  • Stephen BoltonStephen Bolton Junior Member Posts: 345
    No dispute about the fact that this is a C issue, however, as per this thread:

    http://www.amxforums.com/showthread.php?t=3733

    I note that this is a newish 'issue' and appears to be related to circuit design in the newer processors only.

    For my own debug purposes I performed an A/B test between 3100 and an NXI. I have a 10m high grade TSP cable and the 'issue' always occurs on the NI and when the same cable is then connected to the NXI there is no fault present.
  • Thomas HayesThomas Hayes Junior Member Posts: 1,164
    Thanks, I missed that tread =) sounds just like what we have going on. In 21 yrs in the field I have only seen this a handful of times and not in a long time. I hope it will be a long time before it shows up again.
Sign In or Register to comment.