ENOVADGX32 causing network flooding

Hi All,

Have you experience ENOVADGX32 switcher causing network flooding?

We have installed about 18 ENOVADGX16/32 switcher at a customer site seated on different VLAN300-302.

Recently we encountered network flooding on VLAN302 causing all AMX control systems and RMS system that are seated on network VLAN302 down. At that point of time, VLAN300 and VLAN301 is working fine.

At first we thought that it was the gateway or the VLAN tagging on IT portion causing the problem but later we found out that it is due to one of the ENOVADGX32 switcher seated on VLAN302.

We have took out the network connection from this ENOVADGX32 switcher to verify and the network VLAN302 back to normal thus we proceed to reboot the ENOVADGX32 switcher, finally everything back to normal.

Anyone knows what is the cause or is there any way we can do to diagnose the root cause of the problem?

It will be hard for us to explain to customer if this scenario happens again.

Your help is greatly appreciated.

Comments

  • champchamp Junior Member Posts: 261
    I suspect it is a network loop caused by the LAN port of a DXLink endpoint connected back into VLAN302.
    If the issue occurs again disconnect all DXLink endpoints and see if the problem goes away.

    The network switch in the EnovaDGX has management turned off so won't be doing anything strange (eg it doesn't have an rSTP server).
  • JasonTanJasonTan Junior Member Posts: 8
    I forgot to mention that this is a replacement set due to the previously installed DGX32 faulty after a few months.

    Before this replacement occurs, the system is working fine and nothing like this happens before.

    Therefore I won't suspect that it is cause by the network connection problem. I have experienced the network loop before in my office due to the wrong connection looping RX box back to same network with the DGX switcher and it really cause the network to go down.

    So I would suspect that there is some configuration in the DGX that cause the problem.

    Can I know if there is network looping problem, the network flooding should occur immediately at least within a day? So we can conclude it is not the network looping that cause the problem for the case here?
  • JasonTanJasonTan Junior Member Posts: 8
    Forgot to mention that the problem arises after 6 days of the replacement set being installed.
  • pdabrowskipdabrowski Aussie Guy Posts: 184
    I'd disable all network ports on endpoints unless ABSOLUTELY necessary, if you must have it enabled, investigate using a physical lock on the DXLINK and ICSLAN ports on the endpoints to stop little fingers from playing with things, the Panduit range of RJ45 locks have worked well here stopping people who don't know what they are doing unplugging critical ports - and also blocking unused ports from getting something connected that shouldn't be.

    http://www.panduit.com/wcs/Satellite?c=Page&childpagename=Panduit_Global%2FPG_Layout&cid=1345564328987&packedargs=classification_id%3D651%26locale%3Den_us&pagename=PG_Wrapper
    (this part goes over a standard RJ45 plug to stop it from being removed, they also have a socket lockout too).

    I'd also check whether you have DXLINK RJ45 outlets accidentally being connected to the IT network, I had an incident here when a Magneta Research Infinea DVI over CAT5 TX endpoint (similar style of Layer 2 connection as DXLINK from what I understand) was connected to the IT network, it did enough to take down most other ports of the switch it was connected to.
  • champchamp Junior Member Posts: 261
    The fact that a previous unit worked for a few months then after replacement a new unit fails really points to the problem being site specific.
    I agree that network loops usually lock up a network quickly, despite this i still think that disconnecting all network connections when the fault occurs is the first thing to try.

    First thing is to isolate the location of the fault. You may be able to trace it to a patch, connector, cable, DXLink endpoint or card rather than the whole switcher.
  • dbilthousedbilthouse Junior Member Posts: 5
    Oddly enough I just ran into a similar issue with a DGX32. I noticed we had some IP flooding due to several devices that kept getting booted from the network. You could jump on wireshark and see tons of unassigned IPs on the network and then they would disappear. A week later, the DGX32 crapped out. We had two on site, but the one that died would get power, but only to the LCD on the front of the unit. DGX ports and Network port would not come up. Swapped it out with a new DGX32, tried moving the LAN/CPU card into the new unit and same issue. Pulled out old LAN/CPU and downloaded config to the new one, powered up fine.

    It would seem what we experienced was the CPU/LAN card failing. In addition when this card set actually dies it prevents the whole enclosure from going through the boot cycle.
Sign In or Register to comment.