Telnet stopped working on a few NI-3100's ??

jsnyderjsnyder Junior MemberPosts: 21
I can still hook up a serial cable and terminal all day long.
but no telnet client will talk to it.
telnet is turned on and on the default port.

any thoughts?

John

Comments

  • Joe HebertJoe Hebert Junior Member Posts: 2,154
    Are you using 4.x firmware?

    I don't know if it's been fixed yet but you need to enable SSH in order for telnet to work.

    It's been reported to tech support.
  • jsnyderjsnyder Junior Member Posts: 21
    Enable SSH to make telnet work???

    Thats the second wonkiest thing if heard of this week!

    And it worked.

    Thanks!

    John
  • viningvining X Member Posts: 4,301
    A few days ago I updated my office and a few clients to the latest v. 4.1.419 and today noticed my telnet wasn't working and my logging function had't been working since the update cuz it couldn't connect either. I checked setting through the browser and telnet was already grouped with SSH so in this version they can't be enabled separately. So I rolled back to v. 3.60.453 and telnet instantly returned and through the browser there isn't even an option for SSH. I can't be the only one with this not working in the current sw version. WTF!

    Edit:
    Now I have to go see what damage this latest firmware did to those clients I updated. I was hoping for some benefits but I should have known better! Actually if their telnet isn't working their daily logs aren't being written and my daily SITREPs will have no message attached. I guess I should have been looking at those attachments to notice they weren't there since the update.
  • viningvining X Member Posts: 4,301
    Ok, this is related to SSH being enabled. Being a dumb a ssI was looking at security settings in my master browser not the system > server settings. In my defense I usually turn this s hit off it telnet not the browser and it has been a routine to turn off SSH since I don't need it. Any way I'm shocked that this has been fixed in the the current 4.x?? firmware. So all will be good as soon as I log in enable SSH and reboot then my logging should work again.
  • richardhermanrichardherman not-so-junior member Posts: 135
    Not anything helpful, but I can confirm this. I turned off: System > Server > SSH and after a reboot was unable to telnet into the master. Never noticed this before, I usually don't change the server settings, I guess.
    After I re-enabled SSH I used telnet to to access the master and turn off SSH there (set ssh port > 0 > reboot). Although I could not telnet into the master after this, according to the webinterface SSH was still enabled. After a second reboot telnet just worked again... something does not seem right here. Probably won't be fixed, either.

    Also using firmware 4.1.419
  • viningvining X Member Posts: 4,301
    Not anything helpful, but I can confirm this. I turned off: System > Server > SSH and after a reboot was unable to telnet into the master. Never noticed this before, I usually don't change the server settings, I guess.
    After I re-enabled SSH I used telnet to to access the master and turn off SSH there (set ssh port > 0 > reboot). Although I could not telnet into the master after this, according to the webinterface SSH was still enabled. After a second reboot telnet just worked again... something does not seem right here. Probably won't be fixed, either.

    Also using firmware 4.1.419

    I doubt it will get fixed either and chances are my systems won't get upgraded to NX masters since I don't see a future in AMX so I don't even suggest upgrading when issues arise.
Sign In or Register to comment.