Home AMX User Forum AMXForums Archive Threads AMX Hardware

NXC-ME260 Firware Freakshow

I just got myself another master to expand my system from good 'ol Ebay. Upon receiving it, I poked around, no password was installed, the firmware seemed to be at my desired level of v2.20.117, and life was good.
I set up the master with my goodies like IP, Name Servers, etc. and wrote some simple code to speak to my "second" array of devices. Long story short, is that this master is just plain acting STRANGE. On reboot, it sometimes never fully comes up to the point of initiallizing the AXLink bus (flashing LED-none), and sometimes it comes up, but my touch panels show not feedback, nor can I control things with it. I tried to troubleshoot it and all the right PUSHES RELEASES and CHANNEL EVENTS are being logged by the master, but the code isn't processing the correct events.
I just realized that when I expand the Master's device in NL Studio, it seems like I have a firmware mis-match. This is what I see:

00000 - NXC-ME260, AMX Corp (v2.20.117)
[OID=1]-vxWorks Image, AMX Corp. (v2.20.116)
[OID=2]-BootROM, AMX Corp. (v2.20.116)
[OID=3]-AxLink I/F uController, AMX Corp. (v1.03.14)
Port - 1

Does this seem right? Anyone else have any idea of what might be going on? Thanks.


  • Options
    NXC-ME260 Firware Freakshow


    I don't think there is anything wrong with the firmware or at least a mismatch as you theorized. It is not uncommon for a major firmware revision for a device such as the Master to have different firmware levels for its individual components. I am running 2.31.137 on my Master (ME/260) and Studio indicates that the VxWorks and BootROM versions are 2.30.135 and the Axlink I/F version is 1.03.14 (same as your Master).

    In short, I would suspect the device is defective or something in the programming since I think the firmware versions are not an issue. You could reload the firmware to 2.20.117 or upgrade to 2.31.137 just to be sure the firmware is not an issue but it is normal for the versions to be different for those components you noted.

  • Options
    I agree to Reese updating the firmware.

    Please also check the following:
    1) How is the Dip Switch set on the mastercard (left beside the front programming port)? If the Switch 1 is ON (runmode DISABLE), only firmware is started but not your program. set it to OFF and reboot again.

    2) Right beside the 9pin programming port, there are some control LEDs. Please check the CR9 (service) LED. In normal cases, it will flash until the firmware is loaded and then it stays off. If it will flash on and on, there may be a problem loading the firmware.
    Please check if the CompactFlash is connected correctly in its socket. If this not helps, try to download the firmware. If this will also not work, the card has to be sent to AMX for repair (in most cases, the CF is corrupt).
    If you set Sw1 to ON and try some reboots, will the master also lockup?

    If you have problems updating the firmware, it can help to SET the Switch1 and to reboot the master. Like shown in 1), only the fiirmware is launched, but no application. Try now to download the latest firmware v2.31.

    When updating from a version <2.30 (like your ME260), you have to download the firmware twice because of changes in the webserver. The first firmware download will break after the 3rd of 4 firmware parts. This is ok. Boot the master and download the firmware again. After this second download, set the Sw1 to OFF, and boot the master. Now it should come to normal operation.
  • Options
    NXC-ME260 Freakshow

    You said you had another master. Are you doing master to master?
    In that case check your system and or device numbers maybe there's something wrong.
    Good luck
    Leo de Blank
  • Options
    AdaptelAdaptel Posts: 41
    Udpate-Problem Solved

    Thanks to all the GREAT info provided by Marc, this master seems to be humming along nicely. I suspected this was a firmware issue due to the strage way it was reacting when I tried to re-update it. I ended up reflashing the chips to version 2.31 as described in Marc's post using the "disable run mode" method described. All the strange behavior went away and is running like brand new again. THANKS a million to all the helpful folks here!
Sign In or Register to comment.