Home AMXForums Archive Threads AMX Hardware AutoPatch Forum

Autopatch 1YDM? Newbie

thepainterthepainter Junior MemberPosts: 69
Hello - I'm coming from an Extron switcher which was working without a hitch until it went belly up (tested RS232 - works). I got an Autopatch 1YDM via ebay (RGBHV) and have tried using the same code but just changing the protocol for the Autopatch which doesn't seem to work. I'm not sure if it's my code or the cable (NULL) that I am having an issue with.
Sample Code:

Original Extron:

PUSH [TOUCH_PANEL, 69] (* BUTTON 69 WAS PRESSED ON TOUCH_PANEL *)
{
SEND_COMMAND PANA_ST50, "'SP', COMPONENT_1"
{
SEND_STRING MATRIX,"'5*1!',$0D" (* CAMERA FRONT DOOR , COMPONENT 2 FAMILY RM*)
}
}

Adjusted code:

PUSH [TOUCH_PANEL, 69] (* BUTTON 69 WAS PRESSED ON TOUCH_PANEL *)
{
SEND_COMMAND PANA_ST50, "'SP', COMPONENT_1"
{
SEND_STRING MATRIX,"'CL1I5O1T'" (* CAMERA FRONT DOOR , COMPONENT 2 FAMILY RM*)
}
}

Any help would be much appreciated.

Thank You

Comments

  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    I believe the baud rate is different for the Autopatch. You can grab the manual on the AMX tech site.
  • thepainterthepainter Junior Member Posts: 69
    Seems to be the same,

    DATA_EVENT[MATRIX]
    {
    ONLINE:
    {
    SEND_COMMAND MATRIX, 'SET BAUD 9600,N,8,1 485 DISABLE'
    }
    }
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    From the manual

    To create a switch: CL#I#O#T or CL#O#I#T
  • thepainterthepainter Junior Member Posts: 69
    Eric - Thanks for your help, turned out that the output I had my Pana TV on was either not working or had something else on it. All others are working now ......... well video only so now I have to work on the audio portion of things.
  • Jim DonachiueJim Donachiue Junior Member Posts: 82
    SEND_STRING MATRIX,"'CL1I5O1T'" (* CAMERA FRONT DOOR , COMPONENT 2 FAMILY RM*)

    Should be:

    SEND_STRING MATRIX,"'CL0I5O1T'" (* CAMERA FRONT DOOR , COMPONENT 2 FAMILY RM*)

    to route Audio and Video

    CL0 - Audio and Video
    CL1 - Video Only
    CL2 - Audio Only
Sign In or Register to comment.