Home AMX Resource Management Suite Software

Changing Lamp Hours in Duet Video Projector

I have a bunch of NEC NP PA550W projectors that I'm monitoring in RMS using the Duet device monitor. The problem I'm running into is that the device monitor is setting up the maximum lamp hours as 2000 hours, but the projectors are rated to 3000 hours. I've tried changing the parameter through the GUI, but on reboot it gets reset to 2000 hours. I'm trying now to change the value in the duet projector monitor itself like this:
DEFINE_FUNCTION RegisterAssetParameters()
{
    RmsAssetParameterEnqueueDecimalWithBargraph(assetClientKey, 'lamp.consumption', 'Lamp Consumption', 'Current usage of the lamp life', RMS_ASSET_PARAM_TYPE_LAMP_USAGE, 0, 0, 3100, 'Hours', RMS_ALLOW_RESET_YES, 0, RMS_TRACK_CHANGES_YES, 'lamp.consumption');
    RmsAssetParameterThresholdEnqueue(assetClientKey, 'lamp.consumption', 'Lamp Life', RMS_STATUS_TYPE_MAINTENANCE, RMS_ASSET_PARAM_THRESHOLD_COMPARISON_GREATER_THAN_EQUAL, '3000');
    RmsAssetParameterSubmit(assetClientKey);
}

And this does seem to work somewhat...
Line    223 (13:25:49.232):: Command To [42000:1:7231]-[ASSET.PARAM-7001:1:0,lamp.consumption,Lamp Consumption,Current usage of the lamp life,DECIMAL,LAMP_USAGE,0,Hours,true,0,0,3100,,true,lamp.consumption,false]
Line    225 (13:25:49.232):: Command To [42000:1:7231]-[ASSET.PARAM.THRESHOLD-7001:1:0,lamp.consumption,Lamp Life,true,MAINTENANCE,GREATER_THAN_EQUAL_TO,3000,true,false,false,0]

But when I look in RMS, the value is still 2000 hours. I know for a fact that this approach works with NetLinx modules, I'm guessing that the monitor is grabbing the value from the module somehow, but I can't find any documentation on how to set the new max lamp hour value.

Comments

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 521
    Have you tried deleting the projector asset at the server then reinitializing the rms client module on the controller?
  • mstocummstocum Junior Member Posts: 119
    icraigie wrote: »
    Have you tried deleting the projector asset at the server then reinitializing the rms client module on the controller?

    I have, didn't seem to change anything.
  • DisplaySystemsDisplaySystems Junior Member Posts: 2
    The problem lays in the projector module itself... Had a similar problem with another projector which was connected to DVX presentation switch.
    The temp solution I did was (ALWAYS BACKUP THE FILE FIRST!):
    - FTP onto the DVX via IP
    - Get the RMS-Asset template folder
    - Copy the videoprojector.xml file over to local drive
    - Edit the xml file (in notepad or similar).. e.g. search for lamhours.. change to value you want
    - Save file and upload it to same place and overwrite the one present

    This solved it for me on RMS, cause if you do it only on the RMS server, it will work until the DVX rebooted. Now it works all the time.
Sign In or Register to comment.