Anyone had problems with Spotify with Nuvo mediaserver and autonomic driver ?

SteexSteex Junior MemberPosts: 7
Hi everyone,

I'm back at a customer's house after a while and it seems that the driver from autonomic used to communicate with the nuvo mps4e isn't working anymore with spotify... you can select spotify and then you can either go to top tracks or playlists ... but it's as far as it goes...

Anyone had the same experience ?

thanks for your feedbacks,

Steph

Comments

  • DHawthorneDHawthorne Junior Member Posts: 4,584
    I'd call Autonomic. These streaming services will often change things without warning third party developers. Autonomic is usually pretty well on top of it, but it may be a few days. On the other hand, they may have a fix for you already.
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,159
    I wrote a multi-panel module for the Autonomcs media server. I'm can tell you that both Spotify and Rhapsody have internal issues that are specific to the box itself. The cliffs notes version of the story is that essentially Autonomicw has fixed the issue with their own web based gui and (may at some time) resolve it in the third party api. I've waited for the Rhapsody fix for over three years. It is my opinion the company doesn't have the resources to commit to fixing the API as most its users use the web based gui. Of course if we could just show a web page or flash app on a TP.....
  • vincenvincen Junior Member Posts: 526
    ericmedley wrote: »
    I wrote a multi-panel module for the Autonomcs media server.
    Would you be willing to share your module for Autonomic ? as the one supplied by Autonomic is really very poorly programmed :(

    Thanks
  • SteexSteex Junior Member Posts: 7
    UPDATE :

    * turns out that some HVAC tech guy installed a second dhcp server on the client's network and I had to reboot most of the stuff... forgot to reboot the nuvo server and since the tunein radio service was working I didn't search deeper... after a reboot of the server everything went back to normal ...


    Thanks guys for your inputs...
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,159
    vincen wrote: »
    Would you be willing to share your module for Autonomic ? as the one supplied by Autonomic is really very poorly programmed :(

    Thanks

    Vincen,
    I'm afraid I cannot. I didn't write it for myself (I was an employee at the time) I still have it and they know I do and have actually authorized its sale. But, seriously, it's broke and it's not an AMX programming thing. it's a part of the API on the Autonomics side and they have told me they will fix it if they can put resources to it. (read: we'll fix it maybe someday) As it stands, it would take too much trouble to retool the module to fix that one problem.

    Without going all "Inside Baseball" on you. My module dealt with the whole multi-panel / multi-zone issue the Autonomics one did not. As any of you who've used that module knows - it is really not designed for more than one panel / more than one zone control. It's basically one panel nailed down to one zone - no ifs, ands or buts...

    Mine accessed all available zones at once and allowed any number of panels to control/get feedback from any of the zones with a hierarchy of panels per zone (to avoid control trainwrecks)

    the feedback issue has to do with the streaming parts of the server. (Rhapsody, Spotify, etc..) The device itself quits sending out feedback that a track changed and all the attending metadata after one play request. So, the display on the panels shows no cover art and sticks on whatever the first song was with a track time of 10 minutes. The search/build a playlist functionality is also mildly broken in such a way that it's really annoying to the client. (And as you may know, they need to be able to build palylists...)

    So, I'm really doing a favor by not unleashing the thing to the world at large.
Sign In or Register to comment.