Home AMX User Forum AMXForums Archive Threads AMX Hardware

"NOT IN CONTROL OF AXlink" error

I am new to AMX. I have 2 EL Touch screens and a Axcent3. My problem
is getting the Axcent3 to be in control of the AXlink. When I don't
have anything connected to the AXlink, the Axcent will do the following:


SO the Axcent is in control, great. As soon as I plug in a touch
panel, I get:

AXcess System Reset

AXCENT III/PRO Integrated v5.04
Copyright 1992-2001 AMX Corp.


The touch panel is set to the same device ID as specified in my
program, 128. Serial Master Mode is off (non iluminated). And it is
set to BUSS MODE. Yet it looks like the Touch Panel is stealing the
AXlink away. Why?
Show Device on the Touch Panel also says, no Master Response.

Any ideas?



  • Options
    First thing I would try would be another axlink device such as a VOL3 to try and narrow the fault down to either the panels or Axcent III. I assume that you have already verifed that there are no shorts in the cables and that the cable runs down not exceed the 'max run distance' for the panels( you have enough power at the panel to run it). Have you tried the panels right next to the Axcent III? Just a few things to check out first.
  • Options
    Serial Master Mode is off (non iluminated). And it is
    set to BUSS MODE.

    Yikes... Sounds like you have some REALLY old firmware in that panel, like - early rev2 or even rev1. It could be one of those settings, a short or reversal in your Axlink wiring, (plugging in a touch panel shouldn't reset the Axcent3) or bad Axlink tranceiver chips in either the Axcent3, the panel, or both.

    If you have access to any Axlink device besides a panel (AXB-VOL3? Anything?) I'd try plugging that in and seeing if the Axcent3 is still happy and in control of the bus or not.

    - Chip
  • Options
    Hi there, I'm working alongside Gliebetronics with his AMX setup, I have an Axcent3 system of my own and I can't work out what's wrong with his, we've been over the wiring about 4 times now and it all checks out, the cable lengths are about 7', going along a desk in a test bench type setup.

    Power is adaquate, two 13.8v power supplies, one feeding the Ax3, the other powering one or both panels, the Ax3 and panels are hooked up with AXM, AXP and Ground wires.

    Unfortunately we dont have any other bits to test the setup with other than two EL touch panels.

    I've written a simple program to run on his Ax3 that monitors IO port 1 for an input change and sets relay1 to high when input 1 is shorted to ground, The Ax3 was sluggish at responding to this input with no panels connected :(

    We're currently letting the Ax3 sit with no backup batteries to let it clear any original program, it seems to accept programs ok, but the AXlinkLED is doing some weird stuff, sometimes flashing once, twice, and 3 times, randomly, with no TP's connected :S
  • Options
    The EL Touch panel take a lot of power Suppy

    AXT-EL+ TiltScreen Touch Panel 1.5 Amps

    I got this out to the AXPower.txt.
  • Options
    Touch Panel ID

    I know this sounds basic, but are the touch panels set to
    different device numbers??

    The earlier posts only indicated a device of 128.
  • Options
    Yes the panels are set to unique device numbers, and we've checked that the Axcent3 is set as a Master on device 1, we've set it to Slave, device 2 and back to master device 1 with no change :(
  • Options
    Right now, after having taken out the batteries and put them back in, the program has cleared. I re-downloaded the program to the Axcent successfully. With nothing connected to the AXLink, the AXlink LED blinks once a second like normal. The program executes like normal too. If I connect one TP, with its power off, to the AXLink all is well. If I connect 2 TP's to the AXLink with their power off, the LED flashes many many times, sort of randomly. 3, 3, 3, 1, 3, 2, 1-long, 3, 3... etc. like that. While the LED is blinking these random codes the program continues to execute at an extremly slow rate. I remind you that the TP's are not even on right now.

    When I power them on, the AXLink goes steady on and the Axcent3 reboots, Then it says Not in control of AXlink in the terminal.

    When I turn the TP's off again it says Has control of AXLink in the terminal, but the LED begins the blinking tantrum again.

    Do you think that a Axcent3 firmware upgrade would help? Maybe also for the TP's?

    BTW, The Axcent 3 is v5.04 and the TP's are v2.50 and v2.51.
  • Options
    I was taking a look under the hood of the Axcent3 and I see that the data pins for the AXlink go directly to a little SP485RCN RS-485 Transceiver chip. I wonder if that was damaged it it's previous life and if that could cause this screwy behavior.

    Link to the datasheet:
  • Options
    Had some simulair problems a long while ago,

    At the end it turned out of a bad power supply. Measuring with a digital voltage meter say that everything was ok. Measuring the output with a scope told us that the dc wasn't dc but single fase. Later we see that a diode has broke down. So be sure you're power supply is ok. Have you tryed to changed them with an other?

    Good luck
  • Options
    Try wiring the panels on a separate power supply from the Axcent III.
  • Options
    I have tried many different powersupplies in many different configurations. In fact, while testing it with my benchtop variable regulated powersupply, I accidentally bumped the voltage knob and rammed 25V inito the Axcent for about half a second. After that it still booted up and runs programs, but the AXlink LED's were dead. Oops. I traced the circuit and discovered a shorted surface mount diode. I replaced it and the LED's work again. Good save there. haha. It is back to it's "normal" state again now.

    I am really sure this is not a power related issue now. Seeing as I got this Axcent3 off ebay I tried to see if the seller would consider a refund. No luck there. Oh well.

    I have one last idea, perhaps that SP485RCN RS-485 Transceiver chip is fried. It is getting the proper 5V to it but the voltages tested across Gnd to AXM and Gnd to AXP differ from Electro's Axcent3. I have sent Sipex, the manufacturer of the chip, a request for a free sample. Hopefully they will send me some and I can try replacing the transciever chip. I can't seem to locate this chip at any online electronics components stores. :-/

    Thanks for the help so far. If I can get a new chip I will definately let you all know in case someone in the future needs help in this weird situation.
  • Options
    DHawthorneDHawthorne Posts: 4,584
    I assume you've tried one panel at a time, but I'm also curious if you've tried some other Axlink device. Perhaps its the Axlink on one of the panels, not the chip in the Axcent.
  • Options
    Yes, I have tried each panel individually with identical results. I have no other AXLink devices to test with. I have won another Axcent3 (the one without the status LED's) on ebay. When it arrives, I'll be able to do more testing. Maybe if I'm lucky, I can slave the messed up Axcent off the new one. I'll definately let you all know how this works out in the end.

    For now I have been using the serial port on one of my TP's to send serial strings to one of the Axcent3's serial ports. This works fine but it's not the same as using the AXlink. :-)

    I have noticed that when I send serial data to each of the 6 serial ports, the RX LED's blink only on ports 2, 3, 4, and 6. Ports 1 and 5 seem dead. BUT, maybe I have them set to an incorrect mode like 422 or 485? I have not messed with that yet.
  • Options
    I have noticed that when I send serial data to each of the 6 serial ports, the RX LED's blink only on ports 2, 3, 4, and 6. Ports 1 and 5 seem dead. BUT, maybe I have them set to an incorrect mode like 422 or 485? I have not messed with that yet.

    If they're set for hardware handshaking (HSON) and you're using a cable with just TX, RX and Ground, the RX LEDs won't blink.

    - Chip
  • Options
    FIXED IT! :-)

    I ordered a replacement chip for the RS485 transciever in the Axcent3 that is at the heart of the AXLink port. The part inside the Axcent3 that I suspected was bad is a SIPEX 485RCN. I ordered a ST485EBD from Mouser.com. It is the same chip, just made by a different company. The hard part was removing the old chip and putting in the new one because they are surface mount chips. I've soldiered surface mount before so it worked out ok.

    I am happy to report that it now works! The touch panels now have the flashing AXlink button and I no longer get any error codes from the LED.

    Thanks to everybody for all the great tips and support!
    Here's some pictures.


Sign In or Register to comment.