Home AMX User Forum AMX Control Products

Hikvision Cameras MJPG

TurnipTruckTurnipTruck Junior MemberPosts: 1,485
Greetings,

Has anyone had some experience pulling MJPG from Hikvision cameras? I have tried all the regular tricks, but come up with nothing.

Thanks!

Comments

  • shr00m-dewshr00m-dew Junior Member Posts: 394
    You need to setup the substream to MJPEG. Go to setup, video, click main-stream and change it to sub-stream, then set sub-stream to MJPEG with the appropriate frame rate and resolution.

    Kevin D.
  • TurnipTruckTurnipTruck Junior Member Posts: 1,485
    That is what I did. I am able to get the MJPG stream to play in a browser and in VLC, just not on AMX panels.

    The URL that I am using is http://IPAddress/Streaming/channels/1/preview

    I had AMX look at it and they told me that there needs to be a file name such as image.jpg

    If you have had success, could you share the exact URL that you used with AMX panels?

    Thanks!
  • viningvining X Member Posts: 4,368
    I had an issue like this a while ago with an HAI camera which basically just required [URL]http://IP:Port[/URL] and I couldn't get it to work in TPD4 resource manager because there was no file name. I think I got the idea from Joe H to instead try sending the params via code to the TP not in the TPD4 file and that worked like a charm.

    CASE 3 is an axis cam with path and file name while CASE 4 is the HAI cam with only the IP:8008.
                 CASE 3://camera 3
                 {
                 fncAxisCam_QueueTPCmd("itoa(iUI_Indx),'^RMF-Camera_',itoa(n),' LG,%U',cTempUser,'%S',cTempPass,'%H',AXISCAM_IP_ADDRESS[n],
                                    '%Aaxis-cgi/mjpg%Fvideo.cgi?resolution=4CIF&compression=50%R1%N0%V0',AXIS_QDELIM");
                 fncAxisCam_QueueTPCmd("itoa(iUI_Indx),'^RMF-Camera_',itoa(n),',%U',cTempUser,'%S',cTempPass,'%H',AXISCAM_IP_ADDRESS[n],
                                    '%Aaxis-cgi/mjpg%Fvideo.cgi?resolution=CIF%R1%N0%V0',AXIS_QDELIM");
                 }
                 CASE 4://camera 4
                 {
                 fncAxisCam_QueueTPCmd("itoa(iUI_Indx),'^RMF-Camera_',itoa(n),' LG,%U',cTempUser,'%S',cTempPass,'%H',AXISCAM_IP_ADDRESS[n],
                                    ':8008%A%F%R1%N0%V0',AXIS_QDELIM");
                 fncAxisCam_QueueTPCmd("itoa(iUI_Indx),'^RMF-Camera_',itoa(n),',%U',cTempUser,'%S',cTempPass,'%H',AXISCAM_IP_ADDRESS[n],
                                    ':8008%A%F%R1%N0%V0',AXIS_QDELIM");
                 }
    
    Maybe this will work for you too.

    Edit:
    I believe I created the resource in TPD4 with bogus params and then revised those params or lack there of in code.
  • jon.gilliozjon.gillioz Junior Member Posts: 7
    That is what I did. I am able to get the MJPG stream to play in a browser and in VLC, just not on AMX panels.

    The URL that I am using is http://IPAddress/Streaming/channels/1/preview

    I had AMX look at it and they told me that there needs to be a file name such as image.jpg

    If you have had success, could you share the exact URL that you used with AMX panels?

    Thanks!

    I found the stream I have it at home and can post it tomorrow for you you have to turn on snapshots too .
  • jon.gilliozjon.gillioz Junior Member Posts: 7
    the stream i use is
    ip address: 192.168.......
    path :Streaming/channels/1
    file /picture

    note i had to lower the main stream resolution to 2 megapixel to get them picture to come up on a ndx-500i . i also had to turn on snappshots.

    hope this helps someone out .
    regards jon
  • bobbob Independent Programmer Posts: 296
    Do you have the HikVision cameras connected to the main network directly, or to their NVR? In case of the later, they are on their own subnet and not accessible from the main network where the AMX controller and TP's are normally.
  • jon.gilliozjon.gillioz Junior Member Posts: 7
    bob .
    yes my cameras are on my main network and not behind nvr .
  • cristithxcristithx Posts: 11

    Protocol: HTTP
    Host:blabla.com:80 - or whatever port you have
    Path: ISAPI/Streaming/channels/102
    File:picture
    User:admin
    Pass:*******

  • I also struggled to get some Hikvision cameras working on an older G4 panel, but just had some success.

    An odd setting within the camera got it working for me, in the web config area:
    Network/Advanced Settings/Integration Protocol-->
    Hikvision-CGI= enable
    Hikvision-CGI Authentication= digest/basic

    TP File, Dynamic Image:
    Protocol: HTTP
    Host:
    Path: Streaming/channels/102
    File:picture
    User:admin
    Pass:*******

    If the authentication works, you'll see the TP in the user management online users. I think it lowers the level of security which might be an issue though...

    Goodluck.

  • I have a Hikvision I'm trying to get working currently. Thank you for the above info, saved a lot of time.
    I can get the stream in a browser but when in TP4 and I try to click on it in Resource Manager- Dynamic Images I get the error "Image dimensions exceed maximum of 2048 x 2048" and of course no image on the panels.
    I have the substream video set to the lowest possible.
    Any ideas of what the problem may be?
    Thanks all.

  • Nevermind...
    Just started working on it's own. Eah.

Sign In or Register to comment.