Strange problem with NI -2100 again

techniquesmethodestechniquesmethodes Junior MemberPosts: 23

I have a NI -2100 loses network connectivity after restart it work just a moment and the problem returns again I installed the latest firmware I did a factory reset and clean disk Now the processor restarts itself and no connection is possible via LAN or program port I tried different flash memory , the first time it works but after a reboot everything returns as before "no connection" I tried every thing I learned in Installer courses, help plzz:(

Comments

  • DraugarDraugar Junior Member Posts: 25
    Hi Technicuesmethodes,
    First verify the DIP-switches, I just did a factory reset on my NI-2100 yesterday and my DIP's are 00000111 if you want to know.
    The master will have it's IP settings set back to DHCP and you need to find this IP. I assume your network contains a DHCP server? For this I use a program called netscan by softperfect, but whatever floats your boat :)
    when you have located the IP adress to the master, open a cmd window and type in: telnet x.x.x.x (you might need to enable telnet client in control panel > software/programs > turn windows features on or off)
    From netscan, you can also enter the unit via netscan telnet client, jsut rightclick the master IP and select open... via telnet.
    here you can do a "set ip" command and follow the instructions.

    If you already have the IP adress:
    Start netlinx:
    >Settings > Active system communication settings > Network > new/edit, change and save > doubleclick the chosen network so the black area gets updated with correct, hit ok.
    go to your online tree and right click > refresh system online tree.

    If nothing else works, reboot your computer :)
  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,467
    Note that if you did a factory reset, or never turned off UDP broadcasts, and if the DHCP is working, you can go to the COMMUNICATIONS SETTINGS in NETLINX STUDIO and "LISTEN" to find any NetLinx on the network...
  • techniquesmethodestechniquesmethodes Junior Member Posts: 23
    Hi guys,
    thanx for your help
    I already set a static IP to my NI-2100 but when I reboot the master there is no connection again, and the Status Led is not flashing
    question: is clean disk erase the firmaware from the CF card and if the master can boot with an empty Card
  • GregGGregG Just some guy... Posts: 249
    Clean disk only erases the code and files the program has saved (or that have been put in using ftp). It will not delete the firmware, nor will it change the master's other settings, like IP address.

    If the status light is on solid green, that usually means the master is not running any user program, this is normal if "clean disk" was run and then the master was rebooted.
  • techniquesmethodestechniquesmethodes Junior Member Posts: 23
    Good afternoon,
    I think Clean disk erase boot files from the CF card when I tried a working CF card in my NI-2100, everything is good except I can?t find my Master in the ?list of active Netlinx Master controllers? when I click on ?Listen? but I was able to ping it and to connect too via Netlinx Studio
    When I made an internal diagnostic with Netlinx I got this:

    Line 1 (10:12:04):: Error sending UDP packet (IP=EFFFFAFB) (Error=65)
    Line 2 (10:12:10):: IPSocketManConnectTask - connect Timed Out
    Line 3 (10:12:10):: CIpEvent::OnError 0:4:1
    Line 4 (10:12:14):: Error sending UDP packet (IP=EFFFFAFB) (Error=65)
    Line 5 (10:13:14):: IPSocketManConnectTask - connect Timed Out
    Line 6 (10:13:14):: CIpEvent::OnError 0:4:1
    The Firmware version is 4.1.404

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file