No one can tell me why this assett doesn't show up in RMS

I'm trying to do something pretty simple: use a module to track lamp hours in RMS.

I've passed my code around to a few others and no one's figured out what I'm missing. It's a little embarrassing since I'm sure it's something simple, but it's eluding me. We work with RMS at my office regularly, but it's been a long time since we set up a new room and I've obviously lost my touch.

Everything compiles. The room interacts properly with RMS, but the projector does not. I can't figure out what is missing to make the projector report properly, or even show up.


Here's the relevant code:

DEFINE_DEVICE

dvmaster = 0:1:0

//Projector
dvEiki_EIPX5500 = 5001:3:0
vdvEiki_EIPX5500 = 41003:1:0

vdvRMS = 41001:1:0 // RMS Client Engine VDV (Duet Module)
vdvRMSGui = 41002:1:0 // RMS User Interface VDV (Duet Module)
vdvRMSSourceUsage = 33002:1:0 // RMS Source Usage Monitor


DEFINE_VARIABLE

(***********************************************************)
(* MODULE CODE GOES BELOW *)
(***********************************************************)

DEFINE_MODULE 'RmsNetLinxAdapter_dr4_0_0' mdlRMSNetLinx(vdvRMS)

(***********************************************************)
(* INCLUDE DEFINITIONS GO BELOW *)
(***********************************************************)

// include the RMS API constants & helper functions
#INCLUDE 'RmsApi'

(***********************************************************)
(* MODULE CODE GOES BELOW *)
(***********************************************************)

#INCLUDE 'RmsSourceUsage'

#INCLUDE 'RmsSystemEventHandler'

(*********************************)
(* RMS NetLinx Device Monitors *)
(*********************************)

DEFINE_MODULE 'RmsControlSystemMonitor' mdlRmsControlSystemMonitorMod(vdvRMS,dvMaster)

DEFINE_MODULE 'RmsSystemPowerMonitor' mdlRmsSystemPowerMonitorMod(vdvRMS,dvMaster)

DEFINE_MODULE 'RmsTouchPanelMonitor' mdlRmsTouchPanelMonitorMod_1(vdvRMS,dvTPCV7)

DEFINE_MODULE 'RmsDuetVideoProjectorMonitor' mdlRmsVideoProjectorMonitorMod(vdvRMS, vdvEiki_EIPX5500, dvEiki_EIPX5500)


// DEVICE MODULE GROUPS SHOULD ALL HAVE THE SAME DEVICE NUMBER
DEFINE_MODULE 'Eiki_EIPX5500_DisplayComponent' display(vdvDev, dvEiki_EIPX5500_Tp, nEiki_EIPX5500, nDisplayPages)
DEFINE_MODULE 'Eiki_EIPX5500_LampComponent' lamp(vdvDev, dvEiki_EIPX5500_Tp, nEiki_EIPX5500, nLampPages)
DEFINE_MODULE 'Eiki_EIPX5500_MenuComponent' module(vdvDev, dvEiki_EIPX5500_Tp, nEiki_EIPX5500, nMenuPages)
DEFINE_MODULE 'Eiki_EIPX5500_SourceSelectComponent' sourceselect(vdvDev, dvEiki_EIPX5500_Tp, nEiki_EIPX5500, nSourceSelectPages)
DEFINE_MODULE 'Eiki_EIPX5500_ModuleComponent' module(vdvDev, dvEiki_EIPX5500_Tp, nEiki_EIPX5500, nModulePages)
DEFINE_MODULE 'Eiki_EIPX5500_VolumeComponent' volume(vdvDev, dvEiki_EIPX5500_Tp, nEiki_EIPX5500, nVolumePages)

//Define your communications module here like so:
DEFINE_MODULE 'Eiki_EIPX5500_Comm_dr1_0_0' comm(vdvEiki_EIPX5500, dvEiki_EIPX5500)

//////////////////////////////////////

Thanks in advance. Let me know if you need more information.

Comments

  • javery1javery1 Junior Member Posts: 21
    Check the status of channels 251 and 252 on vdvEiki_EIPX5500. RmsDuetVideoProjectorMonitor won't register the asset until both are On. I'm not certain, but you may need to define the projector module before the RMS projector monitor module.
  • deepforestgreendeepforestgreen Junior Member Posts: 51
    Sorry for the slow response on my part. Some outside factors are keeping me from trying this out. I'll let you know within a day or two. Thanks.

    I tried turning on 251 and 252 manually. I did this in control a device and later I added to the ONLINE: commands for that device. Didn't see a difference. But next I'll try to define the module sooner. I'm always confused about the order of those things, and I haven't located the part of the documentation tells us the order in which we should define our modules.
  • fogled@mizzou[email protected] h4x354x0r Posts: 535
    The device does need to be hooked up online, before it will be reported or show up in RMS. But, if you go in and manually turn on 251 and 252, it should fake the system out and trigger the registration regardless.
  • deepforestgreendeepforestgreen Junior Member Posts: 51
    Turns out there was a compiler problem. I was missing some files, but the compiler didn't warn me. I had multiple instances of Netlinx Studio open, and when I closed them and only opened one at a time the compiler worked and told me about the files I needed to add. Of course, I should have added these to the project in the first place, but normally Netlinx stops me when I'm missing something. Apparently I should not have Netlinx Studio opened twice.
Sign In or Register to comment.