TPcontrol connection issue

Im having a problem with a nx3200 running the latest firmware, When a iPad connects it comes online then almost straight away goes offline. In the diagnostic window i get a load of messages one saying something along the lines of "could not open outside port" and the other says "Ethernet port might not be available" any idears what could cause this and a fix. Netlinxs can connect fine.

I have tested it with simple code just one button event that sends a beep and same problem.

Comments

  • a_riot42a_riot42 AMX Wizard Posts: 1,619
    Curious. I was seeing a similar problem recently on an older job that was running a NI4100. Its ran fine for years, but for some reason an iPad would come online and immediately go offline, like a duplicate device ID was in use, but there wasn't. I thought it might be a device trying to connect after a trial license expired, but TPC said that's not likely since the license check only happens once. I rebooted the system and iPads and everything returned to normal but never got any idea why that was going on. I don't recall the exact error messages, but it was the same or similar to what you see when two touch panels have the same device ID. "Connection closed by peer", etc.
    Paul
  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,536
    Paul, your 4100 issue seems like something we see on systems with a number if IP controlled devices. Especially if there are a lot of panels. We presume it results from the NetLinx IP resources getting used up faster than they are released, losing ground across days or weeks, finally being unable to open new connections. Including to TELNET, FTP, and usually last, STUDIO. Meanwhile, existing connections work until they are dropped for whatever reason, and can't be re-established. iPads and Androids are known to flap the IP connection much faster than makes sense, eating resources faster. Running a bank of TIVO's on IP control also accelerates the IP blockade. A reboot of the NI resolves it until it returns...but there's no reasonable way to detect the issue before it bites.

    At sites where it is seen often, we generally schedule a 3AM reboot once a week, and never see the problem again.
    We are also doing what we can in our code to never open an IP connection that isn't actually in use or doesn't need reopening.

    This does NOT address Andrew's issue... which appears to be ALL THE TIME.
    For that, I would suggest substitution of an AMX panel for the iPad and seeing if it changes the results.
  • Reese JacobsReese Jacobs Junior Member Posts: 342
    Andrew,

    What is your security configuration on the NX-3200 in particular with respect to device connections to the master? I ran into a problem where the User ID used for TPControl authentication to the master did not have sufficient permissions in order to perform the functions required by TPControl. Initially, I used the same User ID for Modero touchpanels but that User ID did not have sufficient permission. I narrowed down the permission set required by then changing TPControl devices to use a User ID with *all* permissions and this worked. I then experimented until I found the minimum set of permissions required for TPControl. This may not be your problem but your symptoms and what you are seeing in Diagnostics are very similar to what I saw when I ran into the permission problem testing TPControl with my NX processors. Note also that in the TPControl setup for a device where you specify the User ID/password, there is a checkbox for ICSP Encryption. This box must be checked if authentication is required since TPControl interprets this checkbox as an authentication/encryption flag. If you do not use encryption but you use authentication, this box must be checked. Initially I did not select the checkbox although I specified a User ID/password since I did not require encryption but without the checkbox selected, TPControl would not authenticate the device User ID to the NX master.
  • andrewsmcandrewsmc Junior Member Posts: 7
    Thanks everyone some very odd reason I rolled the firmware right back and the reinstalled in stages and it now works lol
Sign In or Register to comment.