Are there any updates for IREdit to allow it to work on windows 10?

jjspeenjjspeen Junior MemberPosts: 1

Are there any updates for IREdit to allow it to work on windows 10?

IREdit version 1.3.79.0 installs on windows 10. BUT hangs when trying to load. Are there any workarounds or fixes

Answers

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 490

    There's a few threads about the "proper" install process in the forums. Running fine on Win 10 here - and never had an issue that I recall.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,526

    Ian, are your Window 32 of 64 bit? I've had marginal better luck with 32. With either, any attempt to cut and paste within the edit area immediately faults to the desk. On 6 different installs. I am beginning to suspect it's not just me.

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 490

    64 bit. To be perfectly transparent I tend to only open it in a class these days for demonstration purposes but even back in the day I don’t recall any major frustrations creating IR files from imported hex codes.

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 490

    And to clarify “back in the day” was 3 years ago with a 64 bit Win10 VM on a MacBook Pro which continues to be booted up regularly.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,526

    Yes, it often allows me to make an IRL from hex codes, but to cut and paste within or between files is 100% fatal on all my and our dealer's WIN10's. I've had to make many a file for other dealers on my XP laptop.

  • jjamesjjames AMX Sustaining Engineer Posts: 2,900

    Are you dealing with an IRN or an IRL? What's the size of either?

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,526
    edited December 2018

    Both, either, any size. Even a single entry. Highlight, control-c or right click CUT (or copy!), boom.
    "An unhandled exception has occurred in your application...."

  • jjamesjjames AMX Sustaining Engineer Posts: 2,900

    The crazy thing is I recently (within the last 4 months) Installed IREdit on my Win 10 x64 machine and it runs just fine. Cut / copy / paste / save as....all works. Not just appears to work, but actually works.

    There should be exception details. Feel free to shoot them to me or post them here.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,526

    No details. It's not a WIN10 dialog, it's coming from inside IREDIT, with and XP styled box. Just says "An unhandled exception has occurred in your application...." then asks if I want to continue or quit. Both do quit, no number or references. I'd post the image but it seems that will only work on the new forum if I host the image. Since you can't delete or edit after one hour, I don't want to post into my dropbox for perpetuity.

  • KielLKielL Junior Member Posts: 18

    I had previously run into an issue running IREdit, but after reading this thread I thought I'd give it another shot. I downloaded and installed all 3 IREdit files from the new AMX website and it appears to work just fine (cut/copy/paste) in Windows 10. I did have to run each installer in "Win XP SP2" compatibility mode with Administrator rights, the install programs refused to run otherwise.

    One problem I did run into is if I left a file open when I closed IREdit, moved the file, re-opened IREdit, it pops up a dialog box you can't see because the splash screen is in the way. You can alt-tab to it, use the keyboard to hit OK, then the splash screen clears and the program appears to work as normal.

    Maybe this is just more anecdotal evidence that IREdit can work in Win 10, but I'm sure there are some fragile dependencies there (such as .NET 1.1). Since NS4 has the "IR Data" tab, I stopped using IR Edit to peek inside files, and thankfully, I haven't had to capture IR from some new device in years.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,526
    edited December 2018

    That's encouraging enough to make me try yet another new install. Widows 10 is a moving target.

    That hidden error box on start has always been an issue with IREDIT in all windows versions.

  • HyyrHyyr Junior Member Posts: 9

    No matter what I try, IREdit refuses to even install under Windows 10.

    I have not used the application in years, as IR is not often used in my commercial environment.

    However, I now need to add an IR controlled device to an existing project, and find that I have no way to edit or open any IR files.

    Has anyone (besides the trainer) actually been able to get this to work? If so, how? Even running the "IR Edit System Files" installer generates errors.

    We need a better IR solution!

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,526

    In my experience, about half the WIN10 machines have had at least partial install success, though crashes in use were frequent. On others, if the install finished at all, the app would not run.

    Last month I tried installing IREDIT again on two WIN10 machines that failed repeatedly before. BOTH did install this time, though they first failed and Windows offered alternate install settings. Then they worked. Even the cut/paste crash I've had on most WIN10 installs that seemed to work otherwise seems to be gone. I can only speculate that the most recent major Windows Updates (they have been massive) have changed this issue.

    Try again, and good luck.

  • HARMAN_quirkHARMAN_quirk Harman Professional Tech Support Posts: 26

    For those having trouble installing:

    1. Download IREditsetup.exe, IREdit System files, and IREdit Database.
    2. Right Click> Properties> Compatibility - set to Windows XP SP3 and Run as Admin on all three downloads
    3. Install System Files first, then IREditSetup, then the database

    If you do have .NET 1.1 installed and are still having issues try this:

    1) Remove .NET 1.1 using the .NET Framework Cleanup Tool (http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx)
    2) Re-install .NET 1.1 using this procedure (http://saranspot.blogspot.com/2009/02/installing-dotnet-framework-11-on.html)
    3) Go through install steps listed above.

  • sentry07sentry07 Junior Member Posts: 68

    We can't get someone to rebuild the installers for operating systems built in this decade?

  • feddxfeddx Junior Member Posts: 140

    I used the method described in the posts above by Harman Tech Support several times and I've gotten no joy.

    There has to be a better way to access the IR Edit software and these files.

  • ericmedleyericmedley Senior Member - 3709 Posts Posts: 4,159

    I just installed it on my Windoze 10 machine using "XP Service Pack 2" compatiblity mode. It seems to work and all the usual functions behave. (No crashes yet)
    I tried copy/paste of IR channels as well as copy/paste hex from my USB IR Capture device.
    All seems to wirk.

    IREdit is one of those apps that I don't seem to use much nowadays. But, when you do need it it's a bear since there is really no other way to get IR into a machine.

    I realize that AMX probably doesn't want to spend a ton of resources on such an old piece of software. But, for heaven's sake, at least give us the ability to send a command from Netlinx directly to the IR port to send the hex values of the IR File. I don't mind managing them in code.

Sign In or Register to comment.