My NI3000's device 5001 is offline

Hi all,

I've just bought myself an NI3000 (as a test machine to trial out new code) and tried to update the firmware, as both were really old. First I tried to update the 5001 device to v1.30.8, but it kept failing after 2000 bytes with an error (which I've forgotten). Anyway, I then managed to upgrade the Master firmware to the latest (3.60.453), which succeeded. However, I still can't upgrade the 5001 device.

I then noticed that I need to point the target to device 5001...but as it is now offline, it can't upgrade the firmware and I have no idea how to get it online so I can upgrade the firmware.

I did initially start by communicating via RS232, but then thought that IP might be more reliable (and the reason why it initially failed).

Any help greatly appreciated.

Cheers,

Gerald.

Comments

  • sentry07sentry07 Junior Member Posts: 52

    I know on the NX masters you can pull the power and hold the ID button on the back and plug it back in. Keep holding the ID button for 30 seconds(?) and it will revert all the devices to the factory firmware. I don't know if the old NI masters have that capability and I couldn't find it anywhere in the manuals. Worth a try though.

  • I did try that, as I also read it somewhere. But by the time I went to try it, I couldn't find where I'd read it, so was going by guess work...but I'll certainly give it another go.

  • viningvining X Member Posts: 4,341

    Can you go to the online tree in studio and see if maybe it got kicked to a virtual. If it has then go to device addressing and set it right.

  • AlekseyAleksey Junior Member Posts: 22
    Could you connect NI via telnet and run commands there?
  • Bingo - vining got it spot on.

    I was thinking in my bed, as you do, that I couldn't have bricked the device by sending the firmware to the wrong place. But I do remember playing with the ID button, so must've accidentally re-assigned it to 32001.

    Now got it back to 5001 and firmware upgraded, so thank you all.

    Oh, by the way, holding down the ID button for 30 seconds on power on does not appear to do anything on the NI3000.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,470
    edited May 11

    Do take note that the old 3000 has a lot less memory and 1/4 the speed than the 3100's, that the V4 firmware for 3100's has some differences, and the new series NX units have a large number of differences that require attention in coding. Not to mention, most 2000\3000 units (indeed, nearly most 2100\3100 units too) by now have bad serial ports due to the well-known capacitor deterioration. So as a lab test platform, note that your platform isn't level.

  • geraldholdsworthgeraldholdsworth Posts: 12
    edited May 12

    Good call with the serial caps...I'll check them out.
    As this is just a test unit, and I only got it for a quid so can't complain. Speed and memory shouldn't be an issue, as nothing too strenuous will be run on it. I've got a 4100 for that.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,470

    Test AMX serial ports by a voltmeter with positive lead on the center pin of the longer row of pins on any of the serial ports, with the negative lead on the shell. Good is a NEGATIVE 6 volts up to NEGATIVE 12 volts. They generally will still work with down to -5.5 volts, but less than -5, or any positive measure will result in ALL RS232 failing while RS422 will still work as it does not use the carrier voltage. Note that the voltage sometimes will fade downward after a reboot, so test again after it has been running for an hour.

    Usually the "moment of failure" spans weeks of intermittent RS232 behavior, and some devices will quit before others, leading you to suspect the individual devices. Measure much under -5.5 volts and you know it's time.

    2000/3000 units are fairly easy to repair the cap, but hard to justify the effort to value. The 2100/3100 use high density board mounted caps and soldering can ruin the board. I typically lose one out of three when I repair them.

  • I was just going to change the cap as a matter of course, but that is something worth remembering for other units I might come across in my work.

    Would this cap also affect the programming port?

    I managed to get in to find the IP address of the unit via this port, but I felt it wasn't very reliable...could've just been me with finger trouble.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,470

    Yes, the programming port is powered by the same caps...

Sign In or Register to comment.