Home AMX User Forum NetLinx Studio

Netlinx Studio 4.4.1914 still unable to load MD/MT panel firmware update

Because no good deed goes unpunished...

@HARMAN_quirk posted a link to the latest Netlinx Studio in another thread.

Some of the improvements are:

4.4 (October 2019, hotfix)

BUG FIX: Fix crash when sending firmware via ICSP

4.4 (August 2019, hotfix)

BUG FIX: Fix loading of large firmware files.

So I decided to try to upload the 1.8.16 firmware for MT/MD panels, which up to now, could only be done with an USB stick plugged into the panel itself.

That still doesn't work. While the panel (MD-1002i) displays a message that it is receiving a file, NS tells that it is trying to get a connection to the panel, eventually aborts and the panel requires a reboot.

Don't know if it supposed to solve this particular problem, but for me it didn't.
Just thought i'd mention it.


  • Options
    jjamesjjames Posts: 2,908

    I just tested this build and transferred 1.8.15 using a VNM and 1.8.16 using an NX 1200 to an MD-700, both without issue.

    • Can you post a screenshot of what NSX exactly says while it's waiting?
    • Have you been able to troubleshoot at all?
    • Are you using legacy ICSP file transfer or HTTP?
    • Have you disabled your firewall if using HTTP?
    • Are you selecting the proper NIC?
  • Options

    @jjames I didn't take this very seriously: I was uploading a non-released firmware with a non-released NSX. Didn't work, big deal.... USB stick still works.


    • Don't have a screenshot and anyway, can't upload anything to this forum. On the 'firmware update popup' in NSX, The 'progress > 'Please select a file to send' fills up, displaying "waiting for connection", just as it does when the targeted device isn't there. After the bar fills up it displayes the popup with the red top, saying something like it was unable to connect, again, just as like the targeted device wasn't there.
    • No, see above and was time constrained.
    • HTTP
    • No
    • Yes

    Immediately after pressing the 'Send' button on the 'firmware update popup' in NSX, The panel displayed the usual Android file receiving bar with a rotating donut, just as it does when receiving normal panel updates. The percentage stayed at 0% and the bar didn't disappear, after NSX timed out, requiring a panel reboot.

    Most of the panels to test with are gone now, but I have one MT-1002, already on 1.8.16. I will try later to see if I can repeat the failed firmware upload. Will post here with the results.

  • Options
    jjamesjjames Posts: 2,908

    @richardherman You may need to configure/adjust the firewall settings for NSX. With HTTP transfers NSX acts as a server so any outbound connections blocked through the firewall won't work.

    As you might notice in the release notes I'm trying to implement some things not only needed for developers but also some things that might be wanted, such as allowing fonts with ligatures. (At the very least, I'm "sneaking" in things that I find useful, helpful, neat, cool, etc. in each release), but priority is always to make sure the core functionality works and this was a big one. I know it's a pain to update via USB - been there, done that too much in the past.

    If we can't get it to work for you by disabling the firewall then please be sure to reach out to tech support so a ticket can hit my desk and look into it.

  • Options

    You can put firmware on a local http server and just send WEBU command to panel with URL to file as parameter.
    Panel will download firmware from web server and update itself.

  • Options

    Old thread, but answering my last post.
    I've since updated 3 or 4 MD/MTpanels with v1.8.14 firmware to v1.8.16 with NS 4.4.1914. This went fine, so don't know what the caused the problem I had earlier.

    I must say, however, that I find it kinda ridiculous that in march 2020, I still get panels with a clearly defective firmware, while the hotfix firmware (that actually fixes the problem) is more than a year old and I have to update with a non released version of NetLinx Studio.

Sign In or Register to comment.