Home AMX General Discussion

Virtual Machine connect to R4

I created a virtual machine to download my panel TP4 changes to my R4. My Win 10 Pro doesn't work - I get an Unknown 6.3 error.
So once my virtual machine is loaded, Win 7 64 bit, when I run AXBLAN_Setup_02_03_03_06 it seems add it, but I cannot find it in control panel/System/Device Manager. The question I have is - how does a virtual machine have access to USB ports in which my R4 is connected? I have a separate machine running same win 7 ultimate and all works fine. But I dont want to move over to it to do downloads to my R4 want to stay in same chair - :)

Comments

  • johnbonz1johnbonz1 Posts: 3

    Update: Got it working on main Win 10 Pro without using Virtual Machine.
    Here is how:
    First thing load the AMX USB Lan software -- if u get error then try this
    --- try running in compatibility mode - right click on USBLAN_Setup_02_03_03_06.exe
    then click on Properties/ compatibility then choose OS to run from Win XP Service pak 3

    this should load this software and you can tell its loaded by:
    In Netlinx, Help, About u can see that the USB Lan is used
    then in TP4 Help about it will show in AMX USB Lan is installed

    Use Netlinx studio on Win 10 Pro machine
    u will hear the double beep meaning R4 is recognized using AMX USBlan.(I didnt hear that before becuase the USB cord was no good so I used aanother one --- Its the cord that made the difference.!!!)

    If they both are then go back to Netlinx and
    Settings / Workspace Communication Settings - u should see 10.0.0.1 AMX USB Lan Link connection
    - Select it, OK, OK, Right click - Refresh Online Tree and u should get connection
    then goto TP4

    Then goto TP4, Transfer, Send to Panel, Virtual Netlinx Master 0.0.0.0, click properties,
    available connections should show - choose 10.0.0.1 AMX USB Lan Link , OK, Connect, then R4 panel should show,
    Select it and click SEND - new panel should transfer

    So its was the USB mini cord all along!!!!

Sign In or Register to comment.