Home AMX Technical Discussion

Duet Failure on Boot

I have a stable system running on a trusty old NI-3100. Recently I tried to implement two modules. One was to run a Roku that was recently added, and most recently a security system. Just to clarify, in my code I would add an include file that I reference in mainline, and in that include file I have my device definitions, module declarations, etc. After adding the module, adding the TP modifications, compiling, and uploading, I would test and find that nothing surrounding the module was working. I then began to look and saw that the VDV for the module device(s) wouldn't even load in online tree. I then tried to reboot and enable diagnostics to see what was happening, and noticed this error "Duet failed to start up, retries exceeded!". When I comment out the include file/module, the error isn't present. I have had a couple calls with support, to no avail. The NI is running firmware 4.1.430. Any thoughts?

Comments

  • HARMAN_ChrisHARMAN_Chris Harman Professional University Posts: 322

    If you choose to open a support ticket, they will be interested in the specific modules you have added. There is a potential for one to be incompatible with your NI series processor. We can also potentially see if we can replicate your setup and issue.

Sign In or Register to comment.