Home NetLinx Studio

Certificate Path for SSH Private Key

Hi everybody

I need a ssh connection from the netlinx master to a server. I want to use a generated certificate for authentication. The RSA certificate has been generated with puttygen.exe.

I already tested the connection with putty and it works fine, however the problem is with Netlinx. I have sent the SSH Private Key to the Netlinx Master (through Certificate Manager). Now I want to open the ssh client with the command "SSH_CLIENT_OPEN". One parameter is the privateKeyPathname(Path to private key). So my question is: How can I find out which path my private key has been sent to? In the example is "/certs/id_rsa" but this does not work.. I already tried "/certs/<nameofmyprivatekey".

Has anybody ideas?

Comments

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 544

    The HELP documentation is misleading.
    The path is known - all that is required is the file name (and password).

  • aleksaleks Posts: 3
    edited September 2

    @HARMAN_icraigie said:
    The HELP documentation is misleading.
    The path is known - all that is required is the file name (and password).

    Hey thanks for the quick answer. I just tried it and unfortunately it still does not work since I get this message in Diagnostics:

    Line 191 2020-09-02 (07:52:00):: No private key offered/not found for ssh authentication for aleks
    Line 192 2020-09-02 (07:52:00):: Unsupported authentication mechanism
    Line 193 2020-09-02 (07:52:00):: SSH failed to open a session

    I guess the file name has to be with a slash at the start and with filename extension? It looks like this:

    SSH_CLIENT_OPEN(dvIP.PORT,cIP,nPort,cUser,'','/Test_Key.ppk',''). I tried without slash and without filename extension as well..

    Edit: Here are some more information from the certificate manager:

    Certificate File: Test_Key.ppk
    Type: NetLinx/SSH Private Key
    Class: User/Private

  • HARMAN_icraigieHARMAN_icraigie Technical Trainer II, Harman Professional University Posts: 544

    If the .ppk file has just been saved from the PuttyGen app then that is a Putty only file format and is incompatible with anything else. The key must be exported as an OpenSSH key from the PuttyGen Conversions dialog - suggest not saving at as a ppk file type.

    The '/' is not used for the file parameter.

    There's a video that walks you through the whole process

    https://use.vg/77VRVK

  • aleksaleks Posts: 3

    Hi Ian

    Thanks a lot for the help, it works fine!

Sign In or Register to comment.