Home AMX User Forum AMX Technical Discussion

IRL file uploaded not validated by processor

Hi dudes, hope y'all fine.
I'm encountering this situation with IRL files.
If i take an old irl file or any ir from amx database and upload it to the processor, it's ok. But if i want to create a new irl, then after upload it looks like if the processor doesn't validate it.

Let me explain.
What i found i could do to know if the file was uploaded and recognized and working is to upload an irl and then try to download it again. Let's say i upload a 1512byte irl. Transfer up ok either done from IREdit or with FT2. Then with FT2 i try to download the irl file just uploaded to DPS. If i upload an old irl file or one from the amx database, it uploads and downloads fine. If i try to upload a newly created irl, then it wont download. It will upload the 873bytes (or whatever size i try), complete fine, but when try to download, it will progress the whole bytes (873 of 873), but will never complete, will stay in status "transferring". This is a symptom of an ir file uploaded that will not work. Confirmed.

The question:
What could be wrong here? A driver or library or anything on my computer? I'm trying with hex pronto codes, the only way i ever did and always worked until now. I tried with two different processors, and with many different hex codes.

Thanks,

Comments

  • martin_szmartin_sz Posts: 2

    after further testing, i found that the irl file wouldn't work if it's size was smaller than 1024 bytes.
    a single command in a driver can easily be copypasted many times in order to make the file bigger, and that would just work.
    hope this helps someone.
    regards

Sign In or Register to comment.