Home AMX User Forum AMX Control Products

SSH Access to MT-1002

fsociety3765fsociety3765 Posts: 2
edited September 8 in AMX Control Products

Hi all,

I have an MT-1002 running v1.8.16.

The SSH access doesn't seem to be working. Unless I am doing something wrong.

I initially made the mistake of trying the default login for NX controllers (administrator/password) but quickly found that didn't work. A bit of RTFM later and I find the default user is "amx" and the password is whatever the configuration password is set to in the setup, as per page 156 of the Configuration & Programming manual.

Connecting with "amx" and using the password I have set doesn't work. If I enter an incorrect password on purpose, it tells me the password is incorrect. If I type my password correctly, it must recognize that the password is correct as it doesn't complain, but instead just kills the connection completely.

What might I doing wrong?

I did want to post a screenshot of the terminal output but this forum doesn't seem to support added images from local disk.

Thanks,

FS

Comments

  • emdx71emdx71 Posts: 10

    If you're using putty to connect you need to set IUTF8 to nothing in the options under SSH,TTY.

  • fsociety3765fsociety3765 Posts: 2
    edited September 9

    I don't use Putty. But I will try it to see if it works.

    I use OpenSSH. I had to edit my ssh_config to support connecting to this device at all. It seems to be using some old outdated ciphers or something... which is interesting considering it's a current model.

  • emdx71emdx71 Posts: 10

    from what I can tell it runs android (jellybean maybe, so 2012-13ish.) so that could be why. The experts here could maybe tell us but its definitely not a recent version of android.

  • jjamesjjames Just another dude Posts: 2,904

    I know you said you said you're not using PuTTY, but take a look at this: https://help.harmanpro.com/Documents/106/G5 Panels and Putty.pdf

    While those steps are for PuTTY, perhaps the setting could be applied to your client.

    @emdx71 is correct - the OS is quite old and SSH has not been updated in quite some time.

Sign In or Register to comment.