Home AMX User Forum NetLinx Studio

Abnormal CPU Usage & typing issue

HenrysotoHenrysoto Posts: 10
edited April 6 in NetLinx Studio

Hello,

I am currently using (i hope) the latest version of Netlinx Studio (v4.4.1914) on Win10 Pro (x64) with the latest updates, on my new Thinkpad P15 Gen2. Netlinx is running with administrator rights.

My issue is about files with around 3k lines of code. When ever i start adding whitespaces, newlines or any characters, Netlinx is stuttering, CPU usage starts to grow and within the next 2,3 or more seconds it just freezes then the new character appears. It's the first time i've been witnessing this stuttering and i've no idea on how to fix that, it's really annoying to work with.

I tried to reset completly Netlinx and remove my personnal preferences (which i've been using for years), but i am unable to fix this issue, I really need some help with that, as you can guess it's just driving me crazy I lose so much time while working on big files, I started using VSCode instead to edit my files but I don't want it to be a solution concerning that issue..

I had no issue on my old hardware (Surface 5 Pro) and was using the same version of Netlinx with the same preferences and the same operating system.

Thank you.

EDIT: Added link to video: here

Comments

  • HenrysotoHenrysoto Posts: 10

    Update: I found out this is happening only when my code is folded. When the whole code is unfold, it's working as usual. Does anyone have this issue with code folding ?

  • SCamphaugSCamphaug Junior Member Posts: 18

    Dude.. I literally came here to call you crazy but... and I haven't loaded this to anything yet..

    Non Folded compiled size 5,792,064 bytes
    Folded compiled size same code 5,792,066 bytes

    I think you win some sort of last easter egg prize or something. That's wild WTF!

  • HenrysotoHenrysoto Posts: 10

    Well.. i am not :D
    Were you able to reproduce this issue with your settings & code ?
    Where did you get these compiled size details ?

  • SCamphaugSCamphaug Junior Member Posts: 18

    I wasn't able to really see too much of a slowdown in unfolding but I did notice that file size difference. I was just looking at the properties of the file in windows but it's odd that the size would change between it being folded or not, given it doesn't even ask you to save any changes there. Let me know if yours does the same.

  • HenrysotoHenrysoto Posts: 10

    From what I experienced there is definitely an issue with code folding but it doesn't happen with all my hardware, my main PC works smoothly and my old surface laptop too, but my new laptop which is a workstation is struggling.. that is so weird. Right now the only fix is to unfold the code, and infinitely scroll though the code the whole day...

    I wasn't able to see a difference in file size though :/
    Is there any chance to get an answer from Harman techies ? This is really an annoying issue..

  • HARMAN_ChrisHARMAN_Chris Harman Integrated Technologies Group (ITG) Posts: 445

    Henry - I fold all of my code and cannot say that I have experienced this issue. I appreciate that this is not helpful in resolving your experience, but it is another data point.

  • John NagyJohn Nagy CineTouch Product Manager Posts: 1,654
    edited April 23

    Looks like the forum editor no longer has a DELETE function. And once you start a message, it remains in the editor until you post it... can't cancel once there is anything in the editor. We still get the 1 hour edit window, but you MUST post or see your draft forever (though only in the topic you started it). While I appreciate the recent additions of adding images and attachments, this no-cancel-no-delete isn't cool. (I'll happily find I am wrong, help me!)

  • HenrysotoHenrysoto Posts: 10

    @HARMAN_Chris said:
    Henry - I fold all of my code and cannot say that I have experienced this issue. I appreciate that this is not helpful in resolving your experience, but it is another data point.

    Any idea on how I could debug that ? This certainly could be an issue from Window maybe hardware acceleration or font processing ?

Sign In or Register to comment.