Home AMX User Forum NetLinx Studio


I'm connecting to a Solstice Pod via HTTPS using TLS_CLIENT_OPEN(). It works to connect to their basic API on IP port 443.

When I try to connect to a different API on the same pod using IP port 5443, I get an ONERROR event with DATA.NUMBER = 19. I don't see error 19 documented anywhere.

Anyone know what IP error 19 is?


  • Options
    emdx71emdx71 Posts: 44

    I think TLS error 19 has to do with the certificate being self-signed. I believe you either have to load a copy of the certificate onto the master or set TLS_IGNORE_CERTIFICATE_ERRORS.

    However I believe you should be able to do just about everything from the standard API. We use it to pull the name, IP and screen key from ours. Unless there is something I'm not aware of, most of the documentation refers back to the standard OpenAPI.

  • Options

    Thanks for your reply. Yes I also have their standard API working on IP port 443, using TLS_IGNORE_CERTIFICATE_ERRORS.

    But their Active Learning API runs on a different IP port, 5443. Using the same code that works on 443, I get the error 19. Do you think anyone at AMX support would know what error 19 means?


  • Options

    Mike - what other text around the error message do you see? I am searching multiple resources and have not yet found 19. Support would like you to open a ticket that they can then run into engineering for clarification. Once resolved, they will update their knowledge base article(s).

    Posting the resources here for future use:

  • Options

    Thanks for your reply. I opened a ticket.

    You also gave me the idea to check DATA.TEXT in the ONERROR event. It contains the following text:

    336151578:tlsv1 alert decode error

  • Options

    FYI, support helped me figure this out.
    For anyone that might be curious, it seems that error 19 means the server threw an error. The Solstice had these snippets in the its log, which kind of echo the DATA.TEXT above.

    Illegal SNI hostname received
    Sending fatal alert DecodeError

    When I use the Solstice's DNS name in TLS_CLIENT_OPEN() instead of the IP number, it works.

Sign In or Register to comment.