Home AMX User Forum AMX Technical Discussion

HTML5 hosting on netlinx

Hello all,

Is there a possibility to host a working HTML5 design on an NX controller ? We are trying to add an HTML5 interface on a NX1200 with js and css, but at this time we only have access to plain text.

The purpose is to host a specific web interface to control light at a customer.

Thank you for help,


  • Options

    Hi Chris,

    Any news on HTML5 and SDK for NX?
    I also want to ask about the near future of the UI for amx systems. I haven't had a chance to try out the MUSE devices yet, but can you tell me if it's already possible to run an HTML5 project directly on a MUSE controller?


  • Options

    Sebastian - you can find the resources here: https://developer.amx.com/html5ui/

    At this time, you can run directly on NX, but will need to host it off of a Muse for now. We are not aware of a technical limitation of hosting on Muse but have not put in the development effort as of yet to identify how to implement. Quirks of the NX controller allowed us to stand up a second jetty web server, but Muse firmware is not currently allowing the same. Our initial approach is off-device hosting for Muse and we will continue to explore feature requests into engineering to enable on-device hosting if product management deems it a priority.

  • Options

    Hi Chris,

    You said that it is possible to run a second Jetta web server on the NX controller, maybe you have an example of how to do it?


  • Options
    HARMAN_ChrisHARMAN_Chris Posts: 598

    @Sebastian - the Web UI module implements this approach. We provide the module, but will not be providing in-depth how-to guidance to achieve the functionality. Like you, we tinker and learn as we go.

  • Options

    @Chris - I'm still new to amx :) After you wrote, I found the WebUI module at https://developer.amx.com/ - I don't know how I could not find it before... I'll try implementing it. Also I'm waiting for news about the same solution for Muse controllers :D

  • Options
    nicolaunicolau Posts: 43

    I am testing the html5 using the React SDK version.
    I willing to customize some HTML5 pages for some of our projects.

    I can run the demo site on my PC (yarn start) and connect to a netlinx master using the emulator page. Everything looks ok.
    But how can I host this demo site on the netlinx master?

    1) From the SDK I buid the project (yarn build), removed the configuration.json file and zipped the folder "build" to a build.zip file.

    2) Uploaded the "build.zip" file to the netlinx master.

    3) From the HTML WEBUI Module did the following (only the relevant part of the code included):

    vdvUiRoom3_1    = 41102:1:0;
    dvUiRoom3   = 0:4:0;
        send_command data.device,"'SERVER.PROPERTY-Duet-Device,',itoa(vdvWebServer.NUMBER),':',itoa(vdvWebServer.PORT),':',itoa(vdvWebServer.SYSTEM)";
        send_command data.device,"'PROPERTY-webui-resources-zip,build.zip'";
        send_command data.device,"'PROPERTY-webui-resources-directory,build'";
        send_command data.device, 'REINIT'; 

    4) There is no configuration file...

    5) On the master system configuration page (http:///web/http/nxmaster/default.html#/home I can see the 41102 device there.
    the web UI URL to access is indicated as:

    When I go to that page, it asks for log (webui role login) but the page is always a blank one.

    What is wrong? Anyone can help?

  • Options

    When I install that on the NX3200 in my test rack, it always works as expected...

    But I saw that issue... can't remember exactly how we solved that problem, I think we did a "clean disk -f -duet", to remove any orphan files, and the reloaded the sample.... what firmware has the NX controller, what's the Duet mem size?

  • Options
    nicolaunicolau Posts: 43

    I was using 1.6.205 with 64 MB for duet mem and tested on a NX-2200 and on a NX-1200. After that, I tried with firmware 1.8.183 and 128 MB for duet mem.
    No success still.

  • Options

    Still thinking about this.... I'm pretty sure I had run it on 1.6 and 1.8 master firmware..

    possibly it was a browser issue... can't remember, sorry. But you may try it with a different browser, or clear the browser cache.

  • Options
    nicolaunicolau Posts: 43

    I have cleared the browser cache and no results change.
    Built also using the angular SDK (npm run build) and get blank pages also.
    I really need some enlightenment here, will try tech support.
    If anyone else here could give steps I would appreciate.

Sign In or Register to comment.