Home AMX User Forum AMX Control Products

Varia-100 Panel command ^AKB not responding as expected.

I am attempting to use the ^AKB command to adjust button text, however when the Varia panel returns the string it doesn't include the ^AKB prefix. I have also attempted to use a custom prefix but still no joy.

this was my initial attempt:
send_command dvTPa_2, "'^AKB-',uVidSrc[1].sName,';Edit Source Label'"

then I attempted:
send_command dvTPa_2, "'^AKB-',uVidSrc[1].sName,';Edit Source Label;enter input name;VidName-;1'"

Best Answers

  • Marc ScheibeinMarc Scheibein Posts: 789
    Answer ✓

    Confirmed... only the value is returned, not any prefix, neither the ^AKB- nor the optional prefix defined in the command. Same with the legacy @AKB- and AKEYB-

    Firmware 1.11.29.

    Should be reported directly to Technical Support....

  • wilmerswilmers Posts: 2
    Answer ✓

    thanks for confirming, I have email tech support

Answers

  • I also did ;)

  • I got a firmware test build v1.11.31, seems this issue is solved with this build. ^AKB- with its parameters, AKEYB- and even an keyboard opened by panel design will have now the corresponsing prefix.

    So we can expect this fixed in the next regular firmware release.

  • emdx71emdx71 Posts: 39

    PKEYP- is the same way, only returns the value and not KEYP-(VALUE)

Sign In or Register to comment.