Home AMX User Forum NetLinx Studio

Problem with ^app command on G5 panel

Hi,

Is there someone who have a exemple of how to use the command ^app to open a browser on specific webpage?

Here is what i'm doing:

SEND_COMMAND dvPanelSPV,"'^APP,show,Browser,[URI,String,http://amx.com]'"

i tried many different way but no one is working. The browser open but not the URI/URL.

Here are other example i tried with URL or URI:

SEND_COMMAND dvPanelSPV,"'^APP,show,Browser,[URL,String,http://amx.com]'"
SEND_COMMAND dvPanelSPV,"'^APP,show,Browser[,URI,String,http://amx.com]'"
SEND_COMMAND dvPanelSPV,"'^APP,show,Browser,URI,String,http://amx.com'"

nothing work

Here is the doc example

“’^APP-,[,

]’”
Variables: None
action: The action to perform on the application. The available actions are:
show: show an app, launch if not visible centered on the screen in a floating, moveable, resizable window.
close: close a running app
close_all: close all running apps
app name: The name of the application to act upon.
param list: The optional comma-separated list of parameter triplets as follows:
,,,...,,,
where:
name: parameter name (e.g.”URI”)
type: parameter type (e.g. “String”) - not case sensitive
value: parameter value (e.g. http://www.amx.com)

Thanks for your help

Best regards

Comments

  • As per the note on AMX-PI2

    If a backslash itself appears in any element, it too must be escaped with another backslash. To access a file on an attached USB drive, the URI must be: file:///udisk/path_to_file. (Note there are three (3) forward slashes after the file: and you must specify udisk to point to the USB disk.)

    Try this:
    SEND_COMMAND dvPanelSPV,"'^APP,show,Browser,URI,String,http:///amx.com'";

  • neoguirineoguiri Posts: 7

    Hi Ian,

    Thanks its working!!! But i still don't understand.

    For me and wikipedia:

    "The backslash \ is a typographical mark used mainly in computing and mathematics. It is the mirror image of the common slash /."

    The note is talking about a backslash and not a slash. That is really confusing.

    Thanks anyway.

    Best regards

  • This one worked on my MXT-1001, to open the webpage of a NX controller with IP 10.68.5.109:
    send_command dvPanel,"'^APP-show,Browser,URI,string,http://10.68.5.109'"

    If you want to call a website by name, like
    send_command dvPanel,"'^APP-show,Browser,URI,string,http://www.amx.com'"
    Your panel needs to have access a DNS server to resolve the name amx.com to an IP address, and needs of course access to the internet.

  • neoguirineoguiri Posts: 7

    Hi,

    It was an example on my first message. I was trying on a IP adresse not a name. But thank you for your advise for the DNS and internet access. I hope to not do this mistake.

    In my case the // doesn't work. I have a popup msg error and the browser doesn't show up. With a /// it's working.

    For your info i tried to connect to QSys UCI web interface but the AMX browser doesn't load the page anyway. Probably due to the browser extensions not to the link. Other links are working.

    Best regards

  • If you need the ///, I would say the url you try to open isn't a regular webpage, but more an application on a drive.

    Is the QSys page loading on an Android device (mobile/tablet)?

Sign In or Register to comment.