Home AMX User Forum AMX Technical Discussion
Options

No RS-232 activity from AMX DxLink 4K HDMI RX to projector

Hi Harmans community,

I work as an AV Support technician and am having some difficulty with one of our AMX DxLink HDMI RX devices potentially not sending commands via RS232 to its connected projector.

I am currently troubleshooting this communication issue in an already established room, so i do not own any programming files etc unless i were to reach out to the original integrator.

A bit of backstory about the devices and current setup:

A DVX-2155HD Master controller that connects to this particular DxLink HDMI RX unit via DXlink ethernet cable and then a 3 pin phoenix block from the unit to RS232 connection to a projector.

When using the rooms push button controller to turn ON or OFF the system, this projector is not receiving RS232 commands to actually power ON or OFF.

The RS232 LEDs on the front of the RX unit have no activity, however everything else works fine (content is passing if you manually power on the projector).

The RX unit is detected in NetLinx Studio and is on the same VLAN as the Master controller.
Just wondering if anyone might have some tests i can try to confirm what the issue might be?
Happy to try some TELNET commands if this helps?

Thanks for your help!

Answers

  • Options
    emdx71emdx71 Posts: 43

    when you say its detected in studio, does it show that its bound to the controller in the online tree? the way you've described it, to me sounds like its perhaps lost its device number or connection to the controller. if you know what it supposed to be, then it might be best to factory default the dxlink box and reassign the device ID/rebind to the master. We've had to do that with a couple of ours. One day it would simply stop working, and a factory default/readdress was necessary. you should be able to find the device number through telnet along with if its bound properly to the controller.

  • Options
    Marc ScheibeinMarc Scheibein Posts: 816
    edited February 13

    can you post an onlinetree report?
    how are the dipswitches set on the RX-RX?

    In worst case I also would do a factory reset of the RX, wait until they com back to the onlinetree as "unbound device", then you can check their ip adress by right-click on it and "device properties". Telnet to the RX and set manually the connection parameters with SET CONNECTION. If all works well, with some refreshing the onlinetree the RX should come up as a dynamic device in the range 32001..32863. This indicates that a basic communication between master and the RX is established. Now re-adress it to a valid device address, either by studio, or by telnet SET DEVICE

  • Options

    So an update so far:
    I have factory reset the RX unit and found that it was unbound within Netlinx Studios.
    I was able to connect it to the Master using TELNET SET CONNECTION.
    The RX is now listed automatically as device 32002 under the 'Dynamic/Virtual Devices' section.

    I can confirm it is still not receiving any RS232 commands.

    I can confirm the dipswitch settings are currently set to ON, ON, ON, OFF.

    I really appreciate the help so far - it sounds like it might be 1 step away from communicating properly but just unsure as to the next step. You mention "re-adress it to a valid device address, either by studio, or by telnet SET DEVICE"

    I tried using SET DEVICE 0 which according to the user manual "A Device Number of ‘0’ means that the DXLink Transmitter or Receiver will accept the auto-assigned device number from the Master" and it prompts that "The device number you have entered is the same as the current device number" - so i am assuming 32002 is correct?

  • Options

    Dipswitch #2 may be set to OFF, but this switch has no effect when connected to a direct DXLink output, like the DVX.

    The device number 32002 is a dynamic device number. On a reboot of the RX or the DVX, it may change again. Set it to a valid device number <32000, e.g. to 6001.

    With the device set to a valid number, the RX uses different port numbers for control the AV functions.
    From the manual:
    Port 1 – Serial
    Port 2 – Not used
    Port 3 – IR TX
    Port 4 – IR RX
    Port 5 – USB
    Port 6 – Video/Audio Output
    Port 7 – Video/Audio Input
    Port 8 (DX-TX only) – Analog Video Input

    So if you want to use the RS232, POrt 1 has to be used.
    define_device

    dv_DXRX_serial = 6001:1:0; // assuming the RX-RX is set to device 6001
    dv_DXRX_avout = 6001:6:0; // commands and responses AV related, e.g. setting scaler
    
    define_variable
    volatile char sSerialBuffer[100];
    
    define_start
    create_buffer dv_DXRX_serial, sSerialBuffer;
    
    define_event
    data_event[dv_DXRX_serial]
    {
      online:
      {
        send_command data.device,'SET BAUD 9600,N,8,1'
      }
      string:
      {
          send_string 0,"'data received: ', data.text"; // output received data to terminal
      }
    }
    

    You may simply test the serial port by shorting the TX and RX pins. When sending a string, you should get the string back.
    If sending a test string by STudio's "Control a Device", the number 6001, port 1 and system 1 (the system number your DVX physically has, default is 1) have to be used.

  • Options
    John NagyJohn Nagy Posts: 1,734

    @TheAVSupportGuy said:
    I tried using SET DEVICE 0 which according to the user manual "A Device Number of ‘0’ means that the DXLink Transmitter or Receiver will accept the auto-assigned device number from the Master" and it prompts that "The device number you have entered is the same as the current device number"

    Since the device is already getting assigned a dynamic address (32002), the device is already in auto-assign mode, so setting it to 0 is to enter the mode it already is in, and here gets assigned the same number again. So the prompt is accurate but not intuitive. Enter any unused address outside the dynamic range (32K) as suggested, and it will stick. Then the ports are accessible as Marc explained.

  • Options

    Amazing! thanks for the help everyone.

    I was able to assign the RX as device '06001' and as you said, it is now within the System.
    I tested the room system again but it is still not responding. No LED activity on the front RS232 lights.

    Im not familiar with the command format Marc mentioned under 'define_device'.
    Do i have to manually activate Port 1 to allow for serial control somehow?

    Apologize, its probably something basic that i am missing.

    Cheers :)

  • Options

    The TX and RX units have this port assignment by design, nothing special needs to be activated. As the unit comes online, it also can't be an issue with wrong dipswitch settings. I never had such fail before, maybe the serial port of the RX is defect....

    Only one more idea... what about the dipswitch settings on the DVX itself, how are they set? If switch #1 is ON, the runmode is disabled, which means the loaded program will not executed, so also the text code above will fail to work....

  • Options
    emdx71emdx71 Posts: 43

    Since the device registers with the controller, I think the issue here is that you need to know what the device in question was originally defined as in code before it fell offline so you can reassign that netlinx device number. So you might want to check with the vendor that originally installed the system to provide code to you.

    You could also test to make sure that the device in question is actually working correctly is to lookup the projector command for say power on, then try and send that as a string under control a device to DPS 6001:1:1.(which would translate to device 6001, Port 1 on the RX box and then the system number

    I think once you have code (if possible) then things will make better sense for you.

  • Options

    @TheAVSupportGuy - do you have the source code for the project or is this deployed and you are trying to get things back to a working state? As @emdx71 points out, the source code will define a device number for the end point you are trying to control. For example - 6010. When you trigger an activity, like projector power on, the system effectively yells out "Hey - 6010 - turn on!" In this example, if no one is addressed as 6010, nothing happens. You assigned it 6001. If this number is not in code, nothing will happen - much like what you are seeing now.

    If I am in your position, I would enable netlinx device notifications for ALL devices and ALL ports. I would then trigger the action you are trying to get working - possibly power on. I could then use the information in the notifications to see where the command to turn on is being sent. You may see in clear text something like 6053. Armed with this info, you could change the device number of your end point to match. Once complete, it "should" work.

  • Options

    Quick video on how to perform this find and seek mission in netlinx studio - https://somup.com/cZnoDpp0Xo

  • Options

    I do not have the source code for this particular room. It is already deployed and i am trying to get things working again because the old RX unit died. I cant reach out to the company who originally comissioned the room as they went under years ago and no longer exist.

    I was able to turn on all device notifications but i am unsure as to what the Power ON command would be to the projector. It is an old NEC PE401H projector.

    I do have spare RX units so i'd be happy to test with those to rule out a potential faulty port on the current unit.

    But yes, i suspect it is just the wrong device number. This is a multi-floor building with other meeting spaces so i will check to see if any other rooms uses an NEC PE401H projector that also has an RX unit so i might be able to confirm what the device number is supposed to be.

    I will report with an update :)

  • Options

    Unfortunately no other AV spaces within the building utilise an AMX RX unit in its design :(

    I can also confirm that the RS232 LED illimunates when sending a string via Control a Device 6001:1:1 and that dipswitch #1 on the DVX is OFF.

  • Options

    if the RS232 TX LED comes, I would short the TX and RX pins, to check that the RX pin is also ok.

    Otherwise it could be the wrong device number for the RX, so the code can't handle the RS232 communication.

    In NetLinx Studio, connect to the system, refresh the onlinetree, rightclick the online tree and do a Onlinetree Report, with this setting:

    This would report all devices found, but also devices that are coded but not online, so we may find the projector device with its device number not online.

  • Options
    KielLKielL Posts: 33

    Nearly 20 years programming AMX, and I never knew about Online Tree Report. Thank you for sharing that, Marc.

  • Options

    Thanks Marc for the info!

    I ran the Online Tree Report and it just lists all of the devices detected within the System and Dynamic/Virtual Device lists - including 06001 the RX unit.

    As you can see, it also mentions 0 devices found for Coded Devices Not Online.

    From here, i think i will try swapping out this RX unit for another, following the same steps and seeing if that makes any difference.

  • Options

    Device 0 represents IP controlled devices - this is normal and would not raise flags.

  • Options

    Hi everyone,

    SUCCESS! i changed the device ID of the RX unit to 05003 and it works!
    i figured as the Master is 5001 and the Switcher is 5002 that maybe the RX would be 5003 !!

    Thanks everybody for your help!

Sign In or Register to comment.