Home AMX User Forum AMXForums Archive Threads AMX Applications and Solutions

i!-TimeManager Server Trouble

I just tried the i!-TimeManager module but I am having trouble with the right protocol(nTmTsProtocol) and server(strTmTsServer) to use. In the module notes it says "Leave blank to read from time server file (time/nist_svr.lst)". Is the file nist_svr.lst a built-in file in the Netlinx Master or it is a file that I need to ftp to the Master? Where can I find the nist_svr.lst file? I jumped the Master Time Clock 1 hour ahead and watch the TimeManager variables in the Debug window, but the time doesn't sync back. The same Master is using i!-EmailPlus, so I know that it has a working connection to the Internet. Any parameter change or successful configuration example will be very appreciated. Thanks!

My current parameters are:

dTmTzName = 'Pacific'
dTmTzDesc = 'P%sT'
dTmTzGmtOffset = -8.0

strTmTzDstRules = 'US'

strTmLocName = 'San Diego'
dTmLocLong = -116.77
dTmLocLat = 33.02

nTmTsProtocol = 2
nTmTsCheckTime = 60 \\Set to 60 seconds for debugging
strTmTsServer = ''

Comments

  • DHawthorneDHawthorne Old Timer Posts: 4,584
    There is a default list of time servers built into the module, or you can specify a particular server (not recommended, they often go off-line and it's not a bad idea to have an alternative).The list you are referring to is optional and must be FTP'd to your master in /user/time if you want to use it. I have had good success simply using protocol 1 and leaving the server entry blank so it uses the default list.

    As I understand it, NIST servers use port 13 and you have to set nTmTsProtocol to 1. The #2 protocol uses port 37 and you have specify a server youo know is using it. Whichever you use, you need to make sure your network doesn't block the port. You may need to exercise some patience when requesting an update - if you have no DNS entry in your master, it will fail the lookup, but try agian using the straight IP, and there is a bit of a delay. Likewise if the server is down and it moves on to the next in the list.
  • RicardoSiqueiraRicardoSiqueira Junior Member Posts: 373
    Thanks DHawthorne. I changed my settings to:
    nTmTsProtocol = 1
    nTmTsCheckTime = 0
    strTmTsServer = ''
    Then I jumped the Netlinx Master one hour ahead of actual time and the time was ajusted correctly by TimeManager after a few hours. Again, thanks.
Sign In or Register to comment.