Home AMX User Forum AMX Design Tools

Dynamic Image Handling Differences - TPD4 versus Modero MVP-8400

I am using dynamic images on a touchpanel to display IP based security camera pictures with a regular refresh interval (will move to Motion JPEG once Modero f/w supports it). In the course of using the dynamic images, I have observed that the Modero MVP-8400 (using f/w 2.43.21) handles dynamic images fetched through HTTP differently from TPDesign 4 (2.3 Build 319) as well as Internet Explorer 6 and Netscape 7.1.

In particular, I created the dynamic images in the Resource Manager and then established a dynamic image as the bitmap for a button on a panel page. Using Resource Manager, to 'Get Live File' or the TPD4 menu item to 'Refresh Dynamic Images', the static JPEG image is displayed just fine in TPDesign4. The static JPEG image is also retrieved and displayed just fine in both browsers using the URL created for the dynamic image. In TPDesign 4, the static JPEG image is displayed correctly in both the Resource Manager window as well as any pages in the touchpanel file that have a button using the dynamic image as its bitmap.

The problem is that the same dynamic image URL does not work on the Modero MVP-8400 - there is no image displayed. One of the devices being used is a Panasonic KX-HCM10 IP camera. Under firmware version 1.12 (camera firmware version), the Modero is unable to load the image. Using the same URL but upgrading the firmware on the HCM10 to 1.80, the Modero works fine.

I suspect that the Modero either supports a subset of the HTTP protocol in contrast to TPD4/browsers or is less robust (or more restrictive) in protocol or JPEG image handling and this explains the reason the Modero does not work when the other applications work fine. Has anyone had similar problems or is anyone aware of http/JPEG image processing differences between the TPD4 application and the Modero?

Note - I have not upgraded to the latest Build 353 (TPDesign 4 v2.3.1) and I know that new Modero firmware 2.46.xx is imminent but I am still using 2.43.21). This is also *not* a network issue since some images work and others do not but all devices are on the same network and accessible to the Modero. Thanks for any insight.


  • We experienced a similar problem. We have a module that dynamically displays album art from Windows Media Center. In order to do this, the module obains a globally unique ID for the album from an IP server running on the Media Center PC and then constructs a url that looks something like this:{65478945-4568-9874-5632-123456897894}

    We tested sample URLs in TPD4, and they worked fine, but wouldn't work on the CV7 TP we were testing on.

    Upon examining the server logs (since that's our app too), we discovered that the touch panel was sending "?" characters in place of the "{" brackets around the GUID, while TPD4 did not malform the http request.

    Untimatly, eliminating the brackets from the dynamic request solved our problem, but that's only because our server application was programmed to deal with that.

    Hope this sheds some light on the issue.
Sign In or Register to comment.