Home AMX User Forum AMXForums Archive Threads AMX Applications and Solutions VisualArchitect

VA Never works

glr-ftiglr-fti Junior MemberPosts: 286
So far any time I have tried using VA 1.2 it either hangs when generating the system or it gives me a message saying an error occurred press OK. This is not very helpful. How am I suppose to get anywhere with such messages and results? I am trying a basic system 1 3100, 1 R-4, 1 CV7I, 1 DMS Pinnacle, and associated supporting cast. Any ideas out there or is everyone having problems with this software?

Comments

  • Spire_JeffSpire_Jeff Formerly Caffeinated Programmer Posts: 1,917
    I have generated a couple systems with VA 1.2 just to view the code it was generating and had no problems. I can't say that I have run the code it generated on an actual system (but maybe soon now that I have a test bench :) ), but everything looked functional in the code. It was a lot better than the old automated code generation programs.

    Jeff
  • glr-ftiglr-fti Junior Member Posts: 286
    I've figured out a few things. When the system hangs I had 11 CV5's, 2 8400's, a R4 along with 8 A/V devices and R4 gateway. It must not be able to handle that. If it can't handle it why does it let me drag them in?

    When I received the error generating I have no idea why but when I start all over I can now generate a system with 1 CV7i, 1 8400i, and 1 DMS-P, and 1 R4. I guess the first couple got corrupted? I'll keep adding and see when it breaks again unless someone knows what is going on. I have a little time today to play but I would much rather be doing something that generates revenue!
  • glr-ftiglr-fti Junior Member Posts: 286
    More info...first the message 'error occurred press OK' was when VA was trying to transfer files to devices that did not yet exist so I can live with that message but if it gave me more info it would be helpful.

    The other problem is caused after adding devices that generate warnings and the warnings popup window grows too big to fit on the screen to show the OK and cancel buttons. It is not that there are too many warnings it is that there is lots of gray space. If you just hit enter it will continue on, not that you would know that from the screen. This is a definite programming error and needs to be fixed.
Sign In or Register to comment.