Home AMX User Forum NetLinx Studio

"Online" events and Axcess devices

Do Axcess devices generate online data_events?

The reason I ask is because I've seen some randomly weird behavior. I just switched to an NI-3000 but have a considerable investment in Axlink devices, so essentially all of my hardware is on the Axlink bus. I moved my code out of startup and into online data_events, but some devices don't seem to work right.

For instance, my AXB-TMCs - if I unplug one and plug it back in, it doesn't reset itself. It does, however, receive the online events if I reset the NI-3000:
data_event [dev_tmc1] {
    online: {
	send_command dev_tmc1,"'CLOCK ',DATE,' ',TIME"
	send_command dev_tmc1,'CK12'
	send_command dev_tmc1,'SHOWCLK'
	send_command dev_tmc1, "'BRIGHT-',cTmcDimdefault"

The next oddity is my volume controllers. The AXB-VOL3s appear to work fine (on system reset - I haven't tried unplugging one and plugging it back in). When I reset the NI-3000, the volume is reset to defaults:
data_event [dev_vol3_1] {
    online: {
	send_command dev_vol3_1, 'P0R30'
	send_command dev_vol3_1, "'P0L',cVolComputerDef"

However, the AXC-VOL control card in my cardframe, which has the same darn code, doesn't take the commands. If I reset the NI-3000 the volume drops to 0. It does accept commands from other parts of the code, it just doesn't run the online event.
data_event [dev_axf1_vol1] {
    online: {
	send_command dev_axf1_vol1, 'P0R30'
	send_command dev_axf1_vol1, "'P0L',cVolLivingDef"

(cVolLivingDef is a constant = '100')

I'm going to run some tests, put some "visible" action into the online events like a call to my text-to-speech processor to see exactly when and how the code is (or isn't) running. In the meantime, any thoughts or advice on this matter would be greatly appreciated.

Thank you!


  • I have experienced that some devices generate an online event before they are ready to accept commands. So i mostly use a wait, something like this;

    data_event [....]
    wait 5
    send_command .......
  • I'll just say that I haven't really experienced any oddities with online: events not happening with AXLINK devices before. We use NI3ks all the time and don't seem to have any issues. Good luck though.
  • Is this still a problem for you?

    I have not noticed any problems with Axlink devices and Online Data_Events.

    Is you Master and NI firmware the most up to date?
  • Yeah, everything is up to date. Firmware 2.30.135.

    I played with this a bit more tonight. Seems it works about half the time. I was testing with an AXB-TMC. The first couple of times I unplugged it from axlink, waited 5-10 seconds, then plugged it back in, it just came up to it's default settings. I tried again just for kicks and it came up and the online events executed and set it up just fine. It's not just this TMC either, another one elsewhere in the house had the problem.

    I added a call to play a sound effect into the online_event status to see whether the TMC was just not getting the commands or what. The beep only played when the TMC would receive it's settings. Which means the NI-3k isn't always detecting when these things come online.

    Anyway, this isn't a huge issue, but it was odd enough that I had to ask about it. Maybe I'll play with a touchpanel later, see if this problem is isolated to certain devices.
  • Did you check the firmware in the AXB-TMC?

    What do you have plugged into COM 1 on the NI?

    Disconnect Com 1and try your AXlink devices again and let me know what happens.

    What happens when you cycle the power to the AXB-TMC while it is still connected to AXlink? (Use a separate power supply to the power pins.)
Sign In or Register to comment.