Home AMX User Forum AMXForums Archive Threads Residential Forum

25 Smtp Port Blocking

ClingpeachClingpeach Junior MemberPosts: 156
My netlinx is programmed to send out many notification emails.
The problem now is that Optimum Online has blocked the SMPT Port 25 server.
I had to sign up with their service for an email account and put in all the right settings.
Still no joy - does anyone have any work arounds for this problem

Comments

  • DHawthorneDHawthorne Old Timer Posts: 4,584
    Something isn't adding up. They can't completely block the port, or no e-mail client would work. Generally, they just block requests to connect on that port so you can't run a server. It's like port 80 and HTML, they will block connection requests so you can't run a web site, but if they entirely blocked the port, you couldn't browse either. So in either case, if your machine requests the connection from a remote server, which is in fact the case for e-mail notifications, the connection should still be established.

    Are you using the i!-EquipmentManager modules? If so, there is a debug variable you can watch in NetLinx studio. Set it to 1 and telnet into your master, and turn notifications on, then trigger an e-mail, and it should tell you precisely where it is going wrong.

    I suspect the real problem is that your e-mail server itself is blocking you, not your ISP. SMTP servers are terrible in terms of security, so many simply block all connections that don't originate on their own subnet. If you are connecting with a different provider than the one that runs the SMTP server, it will refuse you.
  • jeffacojeffaco Junior Member Posts: 121
    I think what she's saying is that her ISP is blocking outgoing SMTP connections. Many ISPs do this (Earthlink, for one) in order to limit the amount of "damage" that their customers can do in the way of distributing SPAM.

    If all outgoing E-Mail is going through the ISP's own servers, then it's much easier for the ISP to control outbound SPAM. They can inplement rules for # of messages/day per user, etc, where the limits are plenty high enough so 99.9% of the users will never know, yet the spammers get stopped pretty quickly.

    So, Clingpeach, if this is what's happening, you have several options:

    1) Ask your ISP about a server that doesn't require authentication (or uses "simple", non-encrypted authentication). No doubt that your SMTP client in the NetLinx master isn't nearly bright enough to handle SSL encryption if so demanded by the SMTP server,

    2) Ask your ISP to allow your specific machine to make an outbound SMTP connection. They are unlikely to do this, but it never hurts to ask,

    3) Run your own E-Mail server, and have NetLinx send there. Depending on various issues, you may or may not be able to read that externally,

    4) Don't use E-Mail, but instead use syslog, and send your syslog messages to a local computer (much much easier to set up and maintain).

    Ultimately, to have the SMTP client in the NetLinx master make a connection, you need an SMTP server that does not require encrypted authentication. If your ISP has that, you should be able to make things fly by setting the correct data for SMTP server information. If not, then consider the options above.

    Good luck.
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    The i!-EquipmentMonitor modules do not themselves generate outgoing SMTP, they connect to an SMTP server of your choice, and they do support encrypted authentification. If you can connect with Outlook from your computer to the mail server, you can use these modules. Heck, you can connect with Hyperterminal and type in the commands yourself; I've done it while testing. That's why I'm saying something doesn't add up. What ISP's block are private mail servers, like Exchange, not clients.
  • jeffacojeffaco Junior Member Posts: 121
    I don't use i!-EquipmentMonitor. But you're saying it supports SSL encrypted authentication (which is what most clients use)? That would surprise me; the SSL support code is "considerable", and it would surprise me if i!-EquipmentMonitor actually did that. SSL support is, essentially, gobs of code. You sure on that?

    ISPs can block access to their servers without authentication. This, alone, seems like a bad idea; I see no reason why an ISP would do that, but they could.

    ISPs can block outbound access to port 25. This is a good idea, and many ISPs do this to reduce SPAM from their network. Those that do this typically do the following:

    1) Allow their own mail servers to be used unrestricted, but only from within their networks,

    2) If you want to use a different From: address or something (like from a work address), they typically have an authenticated server that (a) Requires SSL-based authentication - most clients support this, and (b) Is reachable from inside their network as well as outside their network (so things work correctly without you reconfiguring your settings based on where you are).

    So, in the end, I still don't fully understand the issue that ClingPeach is having. She should likely contact her ISP and figure out exactly what was changed, and how she might work around it.
  • DHawthorneDHawthorne Old Timer Posts: 4,584
    You're right, I read your post too fast and let me confuse myself :). i!-EquipmentMonitor does Base64 enCODING, not SSL enCRYPTION, and yes, I understand we are talking very different things for very different purposes. Not enough coffee when I posted that :). It does support authentification.

    What I suspect, though I worded it differently in my first post, is what you stated in your point #1. She may be trying to access the mail server from a connection that is not on the same network as the mail server.

    The only other thing I can think of now I'm a little more awake is an over-ambitious firewall, hardware or software.
Sign In or Register to comment.