RMS Dashboard issue?

I'm in the process of setting up RMS (MeetingManager), and have the benifit of not going live just yet. I've got the server up and running and added a test NI-3100 to it okay. I used CodeCrafter to create the initial code, paticularly for adding two data projectors. Looks fine. Added system power calls, hey presto! That is working like a charm.

Given that I haven't been through this process before, I made the mistake of adding a "LAMPTIME" parameter with CodeCrafter. Of course the proj module already takes care of this (with the "Lamp Hours" param), so I decided to delete all references to my LAMPTIME param in RMSMain.axi. Recompile, upload to NI-3100, reboot. I'm not totally sure, but I think it may have been the cause for the following issue:

When I try to go to the RMS Dashboard, an error page comes up. (MeetingManager/system/error.aspx) with the following message:
Exception Encountered
Input string was not in a correct format
Please contact your system administrator
It is shown regardless of who logs in. Using my browser history, I can still get to the other pages of my session, but it appears as though I have somehow corrupted the Dashboard.

Any clues as to what I have done wrong? Any suggestions for restoring the dashboard? I hope I don't have to do a complete reinstall on the server side, but if that is what it takes then so be it.

RMS v3

Roger McLean

Comments

  • RMS Dashboard error - Exception Encountered

    That issue is fixed in Beta build 29, and will be fixed in the upcoming release. It is due to a lamphour threshold being written in with ascii characters in it, most likely the word "hours" was written in the threshold. Thresholds can be integers only. The word "hours" is appended automatically in the normal case. If you enter it with anything but an integer, it allows it to be saved, then errors the page when you try to open it. It cause the dashboard to error because of the lamp hour module in the dashboard. The fix for now is to browse to rms/hotlist.aspx to be able to get away from the dashboard. Then go into lamphours in all the rooms and look for any threshold that says "hourshours" In the new build, we drop anything but the integer when the thresholds are saved, eliminating the chance for any errors.
  • annuelloannuello Junior Member Posts: 294
    Ah, that fixed it. I can see that when I modify the parameter threshold, the ASCII "Hours" is automatically put in to the field. When I was exploring earlier, I must have clicked "save" even though I didn't change the paramter myself. The automatically-inserted "Hours" was saved in the integer field.

    Thanks Doug. Looking forward to the next release.

    Roger McLean
  • dunnpdunnp Junior Member Posts: 12
    Lamp hours

    Also be careful when changing the lamp hours threshold trigger point. RMS appends the word 'hours' when 'Save' is clicked and then generates the same error when any query involve lamp hours. Example:
    changing '2000 hours' to '1950 hours' results in '1950 hours hours'. If you want to change to 1950, overwrite the '2000 hours' with '1950'.
    Even pressing the 'Save' without changing anything appends and extra 'hours'. As stated above it will be fixed in the next realease, but it's a 'gotcha' right now with 3.0.26.
    ...Phil
Sign In or Register to comment.