Home AMX User Forum AMXForums Archive Threads AMX Applications and Solutions

R4 not seen by USB ports on Laptop

Hi All,

Got and interesting fault, got my first R4 job and upgraded my laptop to the latest AMX USB driver, 2.3.3.6 from my previous version. Have now spent a day on site trying to get it to connect with no success, also spent the morning of the 24th December in AMX York office with my ex work collegues and still no joy. And now it doesn't even talk to the panels over USB (MVP 7500 or MVP 8400)..

The driver install and windows does its Bong Sound when i connect the device, it finds the new hardware and device and installs it for the USB port connected.. when looking at device manager it shows under network adapters AMX USB Lan and the driver date checks out with other laptops we have checked too here in the office..

Anyone got any ideas at all as this has got us all completely vexed!..and at the moment means i can not do R4 work? a little bit frustrating..

Laptop just so you know is a Dell Latitude D620, with 4 usb ports of which none of them work with the R4's or MVP's over USB?

Merry Christmas everyone, Stuart

Comments

  • viningvining X Member Posts: 4,368
    Are you changing the R4 from Mesh to USB in protected set up and then rebooting? Are you changing the communications settings in TPD4 or NS2 to "Virtual Master". Once the R4 is booted in USB mode then connect you USB cable to you PC abd give it a couple of minutes to be discovered.
    And now it doesn't even talk to the panels over USB (MVP 7500 or MVP 8400)..

    Set you connection type of the MVP to USB and reboot. Set TPD4 or NS2 to "Virtual Master" just as with the R4 above.
  • Stuart BeggsStuart Beggs Junior Member Posts: 14
    Hi thanks for that, should have said i used to work for AMX technical support so i've tried all the basics and know about the delay times off USB devices coming online in Virtual Master mode.. even tried using different USB cables just in case mine had a bad kink in or something heavy had been placed on it..

    everything was set in USB mode, i even uninstalled all my USB drivers in device manager and then reinstalled them all? not sure what else to do, even manual copied the latest 'AXBLAN.sys' file into the system 32 driver founder just to make sure it wasn't using an older one and was being replaced.

    What confuses me is windows clearly see the device connected on USB as it launches the AMX LAN ADAPTER under the network adapters.

    Just wish there was another way of downloading to them . i.e. even over Zigbee, i know there are bandwidth issues but if they limited the transfer of data i reckon it would work as from what i've seen the tpd4 files aren't huge.

    Many thanks for your reply,

    And a happy new year to all
  • BigsquatchBigsquatch Junior Member Posts: 216
    Me and a co-worker have similar problems.

    http://www.amxforums.com/showthread.php?t=3371&highlight=r4

    Neither of us have found a solution but it's good to know that were not the only ones who have experienced this problem.
  • Jimweir192Jimweir192 Junior Member Posts: 502
    What IP address do you get for the AMXLAN adapter?

    When ever I've had problems its due the the IP address coming up as a default Windows alternative IP rather than the Device ID map 10001=10.0.0.1
  • IshlachiIshlachi Junior Member Posts: 34
    We had this issue for a while. Our network uses 10.0.0.xxx. The AMX LAN program defaults to 10.0.0.1. If this is your gateway, it will either drop your network connection or not see the R4. Try disconnecting your laptop from network and then reconnect. If it works, then use the USB LAN utility to change the default IP address to something outside of your local IP range.
  • KennyKenny Junior Member Posts: 209
    I had the same issue on my previous laptop. It was a Fujitsu.
    It never would work over USB with AMX products.
    AMX TS had no ideas on how to get it working.
    My new Toshiba running Vista works fine.
    I believe that is the first nice thing I have said about Vista. :)
  • Stuart BeggsStuart Beggs Junior Member Posts: 14
    Hi thanks for all your replies,

    I'm pretty sure i tried with my laptop connected to my network and completelty disconnected.

    Whats interesting though is the AMX USB LAN Utility program, i looked in the folder that the files were installed in and couldn't find it and also checked the AMX website using their search engine? what i did find though was 2 programs that must have been installed from previous AXM USB installs,

    1 was "usblan_ifconfig.exe" the other was "usbview.exe" not sure what either of these do and unfortunately i haven't got a Mio-R4 to test with now, although after xmas i may be able to drop into an office and borrow one.

    There is nothing in the readme.txt about this USB LAN utility either? is it something i have to get AMX to send me?

    Thanks all,

    Stuart
  • DavidAlexanderDavidAlexander Junior Member Posts: 1
    Solutions

    Hi Stuart,

    I had someone in the office the other day with a similar problem ;-)

    What I found was there are too many instances of the AMX LAN Miniport drivers which windows installs each time the R4 is connected. They unfortunately do not remove themselves. We also found that in TPdesign4 and Netlinx Studio2 if you go to Help/About the version number of the AMX USB LAN driver said 1.0.0.0 and not 2.3.3.6 (the current version number of the AMX USB LAN drivers!

    What we did:

    Firstly uninstalled the AMX USB LAN Windows Driver utility. Then in device manager removed all the instances of AMX miniport drivers they can be seen by right clicking on my computer, then going to device manager, where it says device manager right click -> view -> show hidden device, they will all now appear. If doing this results in the follwing message:

    "Failed, unable to remove driver, may be required to boot windows" etc for the following can be done first:

    Right click on My Computer -> Properties -> Advanced -> Environment variables.
    Add a new system variable called "DEVMGR_SHOW_NONPRESENT_DEVICES" and give it a value of 1. Now go back to device manager and show hidden devices. More of these miniport drivers will appear but "greyed/washed" out. If you remove these it will take the higher form with it allowing you to remove all instances of AMX USB Lan miniport drivers.

    Reboot machine, install AMX USB LAN drivers again, connect R4 in USB mode, start Virtual Netlinx Master and hey presto works!

    N.B. when the Virtual Netlinx Master is running go to network connections, find the Local Area Connection that respresents the USB AMX LAN and make sure that there is no firewall on as this can also create problems.

    David Alexander
    RGB Communications Ltd
    AMX Technical Support
  • a_riot42a_riot42 AMX Wizard Posts: 1,619
    Sounds like a firewall issue to me. Have you turned your firewall off and tried? Are any ports being blocked?
    Paul
  • kmenshousekmenshouse Junior Member Posts: 32
    Here was my problem

    I was having the same described problem. I finally stumbled upon the fact that I had not selected the IP for the USB Lan to work from. I did this by clicking on the Transfer>Connect option. I was showing virtual master but not with an IP address beside it. I clicked properties and could see several network connections (i.e. wired, wireless and AMX USB Lan). When I closed the box it prompted me for an IP. I finally clicked on the AMX USB in the list and it supplied the 10.0.0.1 IP address. After that it connected fine and away with the transfer! I am also using Vista. Hope this helps.

    Keith
Sign In or Register to comment.