Home AMX User Forum AMXForums Archive Threads AMX Hardware

R4 - I can't download to r4 my project. Why?

Hi! I'm trying to download to my Mio R4 panel a project from TPdesign4.
1- I have the last USB LAN
2. I set R4 to usb and Reboot
3. I connect usb cable
4. In TP4, I connect to Virtual Master
5. In send Panel, TP4 says that no compatible devices is present!

How can I connect and download my projects?
Thanks a lot


  • viningvining Posts: 4,368
    I never had an issues connecting and transferring to the R4 from TPD4 until my last attemp where I finally just gave up went through NS2 which worked fine. I have no idea what the problem was or is.
  • TworhythmsTworhythms Posts: 51
    I have had endless problems transferring to these remotes. The only thing that worked for me was to open up studio while the remote was connected and while TP4 was open and then choose Virtual Master in studio and perform a network refresh. Once the remote appears in studio then it appears online in TP4. I am still scratching my head as to why this method works and connecting by simply opening TP4, doesn't. I am also using all current software builds, firmware etc... I brought this up to one of the tech guys and they didn't seem to have an answer either. Hope this helps!
  • eddymouseeddymouse Posts: 67
    I'm going crazy!
    So I make this steps but nothing work!

    1- R-4 in USB mode and Reboot ( id device is 10002 )
    2- I connect R4 by usb cable to my pc (win2000) and the system give ip address to the connection ( AMX USB LAN is the last)
    3- I open NLinx Studio and I set the Communication Setting to Virtual Netlinx Master with Avaiable Connection to
    4- I go to online tree and Refresh System. this is what I see:
    00000 - VNM, AMX Corp. ( VNM Version 1.2)
    32001 - NSX Application, AMX Corp ( v.
    and I don't see the 10002, my Mio R4
    5- I open TP4, go to Connect, select Virtual Netlinx Master with ip
    6 - TP4 connect
    7- if I select Send to Panel the window say No Compatible Device online (with filter R4)

    How can I upload my files?
  • BinuBinu Posts: 49
    I followed the same procedure and its works for me

    Please make sure AMX USB LAN link is active on your system properties.
    i1.JPG 74.9K
    i2.JPG 59.3K
    i3.JPG 52.8K
  • eddymouseeddymouse Posts: 67
    In picture 1 I don't see the 10002 line (and childs).
    In picture 2 I don't see the 10002. It'say no device online
    Picture 3 is ok.
    Maybe the problem is Win2000? Now I'm installing the system on winxp.
  • eddymouseeddymouse Posts: 67
    I have installed all the program (netlinx and tp4) on WIN XP pro.
    I have conntected r4 with usb cable. But nothing work! I don't see r4....
  • BinuBinu Posts: 49
    Is this R4 getting connected to your master via zigbee??. If not it might be a hardware issue.

    Try with another USB cable

    Try in a different PC
  • eddymouseeddymouse Posts: 67
    If I connect R4 via ZigBee I see the R4 but I can't upload/download file.
    I try with different cable and different pc.
    Now on my laptop with Windows xp pro, If I open TP4 and connect I see the R4. Then I open Netlinx and I see th R4. With the other pc with win 2000, don't work. Why? Boh....It's a miracle!
    Thank you
  • eddymouseeddymouse Posts: 67
    Don't work!!!!
    On WinXPpro It work for once time! Then I rebooted the Pc and R4 is disappared!!!
    Now online one times this moorning I see the r4 on TP4/Netlinx.
    Now TP4 say no compatible Device and Netlinx don't see it.
    I have tried many configuration, cables and pc.
    Why I can't see it? It's not possible!!!
    Where is the error?
    I think Panel File download over zigbee was never intended to work. or i have missed sth. the only way is to connect over usb. the way described above worked well. try to call tech support if you are stuck
  • eddymouseeddymouse Posts: 67
    I use ( ...I'm trying to use... ) usb connection....
  • DHawthorneDHawthorne Posts: 4,584
    I have found that once you have done all the above steps, if you enter the panel setup again, then set it back to mesh without rebooting that it will appear in the device list. I haven't nailed down exactly when in the process it appears, but since I set it to mesh anyway so it will be online after a load, this hasn't been a problem to me. Consequently, one must remember to reboot it after setting it to USB as well; the setting doesn't take until after a reboot.
  • eddymouseeddymouse Posts: 67
    I'm rebooting everytime I change mesh to USB and viceversa..
    But nothing change.
    This morning when I start the pc, I see the R4 in the TP4. So I downloade my file. Then I set R4 to Mesh and then reboot. And The R4 Worked!!!
    Than I need to make a modify to the file and so I set R4 to usb and reboot R4. Then nothing, R4 is disppared and I never seen again.
    I'm crazying....
    Thanks Alex
  • DHawthorneDHawthorne Posts: 4,584
    This is what I do, and it seems to work every time. I'm not sure my previous post was clear, so disregard this if you have already tried it:

    1. Set R4 to USB, REBOOT
    2. Connect TPD4 to the virtual master on the USB Lan
    3. Physically connect the R4 to USB
    4. Go back into setup on the R4 and set to mesh - DO NOT REBOOT, just exit out of setup
    5. R4 appears in device list
    6. Load file, R4 will reboot when its done and be connected via mesh
  • eddymouseeddymouse Posts: 67
    I'm sorry. But don't work. I can't see R4 in device list.
  • AvophileAvophile Posts: 70
    I wonder if this cryptic note in the read me file that comes with the USBLAN installer has anything to do with this problem:

    2. Known Issues - This section contains the identified
    issues that this version is shipping
    of the product contains...

    - It is strongly recommended that the user disconnect all
    AMX USB devices from the target computer prior to
    installing/updating the AMX USBLAN driver.
    After the installation completes, the user should
    re-connect the USB device(s) to the computer, which
    should detect the device and invoke the New Hardware

    I was also suffering from the disappearing R4 issue yesterday.

    The first load went smoothly. Subsequent attempts failed.

    When I tried uninstalling and reinstalling the USBLAN, I kept getting an error at the end of the "New Hardware Wizard."

    I thought I tried David's procedure but I will try again today. I may have rebooted after changing back to Mesh.

    I still don't get why we are supposed to switch back to mesh before transferring over the USB!
  • viningvining Posts: 4,368
    Avophile wrote:
    I still don't get why we are supposed to switch back to mesh before transferring over the USB!
    It's merely a short cut so when the file finishes transferring and the R4 does its reboot you reboot into Mesh Mode and should shortly be online. Otherwise after file transfer and its subsequent reboot you have to go into its system pages select Mesh and reboot again. It simply saves you a step in the BS process and two additonal minutes of waiting.
  • gusgizmogusgizmo Posts: 15
    I had similar pains when I first started working with the R4. My two problems (on windows XP sp2):

    1. Bad USB cable. Worked for other stuff, not the R4.

    2. Bad installation of USBLAN driver. Had to go to devmgmt.msc and remove the driver, restart, then reinstall.

    After going through that, I stopped having problems. Might not hurt to firmware upgrade the units either, it's pretty much mandatory if you want your client to be happy. Oh, and to keep your hair.
Sign In or Register to comment.