Home AMX User Forum AMXForums Archive Threads AMX Applications and Solutions

i! Schedule

glr-ftiglr-fti Junior MemberPosts: 286
I recently installed the i! Schedule module on a job. It arbitrarily changes the displayed time on panels 1 hour ahead. There does not seem to be any consistency as to when or why it does it. If I remove the module everything is back the way it should be.

I am using the following values:

dTmTzName = 'Central'
dTmTzDesc = 'C%sT'
dTmTzGmtOffset = HoursFromGMT // calculated in program currently -5
strTmTzDstRules = 'US'
strTmLocName = 'Green Bay'
dTmLocLong = Longitude // constant
dTmLocLat = Latitude // constant
nTmTsProtocol = 1
nTmTsCheckTime = 0
strTmTsServer = ''

When I called support the dude I spoke with didn't even think the module had time settings so I obviously did not get much in the way of support.
Any ideas? Thanks.

Comments

  • Stephen BoltonStephen Bolton Junior Member Posts: 345
    Couple of questions...

    Have you entered vals in for a time server in your code?

    What settings are in the Masters Clock Manager - particularly DST area?

    Most if not all of the clock code is now in the Master firmware under SYSTEM > MANAGE SYSTEM> CLOCK MANAGER - perhaps the code and the masters version are conflicting..
  • glr-ftiglr-fti Junior Member Posts: 286
    According to the i! Sched doc: "For simple Date Time synchronization, select DayTime (value=1) and leave the server field blank. A default NIST server will be selected." This is what I did.

    The DST settings on the master are ON, offset 1 hour, the normal start and end times for US, and the NIST is 132.163.4.101.

    Thanks.
Sign In or Register to comment.