Home AMXForums Archive Threads AMX Applications and Solutions VisualArchitect

Installing VA 1.3 issues.

cmatkincmatkin Senior MemberPosts: 86
Hi,
I am trying to install VA 1.3 from my CD and it stops on Copying file: C:\WINDOWS\Amxbold_.ttf
Has anyone had this issue, or does anyone know how to resolve this.

Regards
Craig

Comments

  • Marc ScheibeinMarc Scheibein Junior Member Posts: 669
    This is a known issue, see Technote 842
    http://www.amx.com/techsupport/techNote.asp?id=842

    Resolution from the Technote
    The resolution is to delete all copies of the font on your PC. Do a file search for all copies, and you should find at minimum a copy in the Windows\Fonts folder. After deleting the file, you must re-boot your PC to register the file deletion. Then rerun the apllication install and it should go fine.

    Hope this helps.
  • cmatkincmatkin Senior Member Posts: 86
    Thanks heaps.
    I had tried the method of removing from the fonts directory, but that doesn't work. There are two other copies on the drive.
    Once all were remove VA installed fine.

    Thanks again.

    Regards
    Craig
  • xAPPOxAPPO Junior Member Posts: 5
    I found three copies of AMXbold and deleted them all , rebooted but the install still seemed to hang here.

    So I need to get past the AMXbold issue as per the technote but there are definitely no AMXBold font files on this machine.. the installer does create one each time but hangs there immediately afterwards....

    Any ideas anyone ?

    Kevin

    <UPDATE>

    After spending the best part of a couple of days and dozens of install attempts on this I've managed to get it to install ...

    After having deleted the AMXbold truetype font file and rebooted I then added a couple of new free truetype fonts that I found on the internet and then ran the installer again and it worked !! Don't know why but I'm glad it did as I was getting soooo frustrated.....
    ( I had also temporarily moved the two AMX icon fonts out of the font folder).
  • xAPPOxAPPO Junior Member Posts: 5
    Arrgh - the frustration continues... and as a new AMX entrant can I just flag how damaging issues like this are in terms of our confidence in AMX's updates and bug fixes.

    I interpreted this issue (technote released July 07) as being one caused by older installers creating a font file that had inappropriate privileges set and hence later installers weren't able to overwrite the file. Fair enough these things happen and having been updated once I assumed it would be gone.

    I'm just setting up a new PC with a suite of the current AMX applications and using the bang upto date current installers (web update) I find I'm still hitting the exact same issue in several other applications (as mentioned in the TN). Surely in well over a year this should have been addressed and the most recent installers work correctly or at least have an option not to try and re-install the font ? (I did notice one app had this)

    All in all not an impressive start....

    Kevin
  • DHawthorneDHawthorne Junior Member Posts: 4,584
    Two factors:

    1) It's not a common issue. I've installed several versions of VA without running into it.
    2) Most of us aren't using VA regularly anyway; the bugs aren't getting reported anywhere near as quickly or as in depth as in a program like TPD4, or NS.

    It's a bad impression to start out with, granted; but I can assure you it's not typical for AMX to have unresolved bugs like that. It just seems this particular one has been flying under the radar.
  • Installing VA 1.3 issues

    The font installation issue is being corrected with a new version of Wise Solutions application installer. The workaround for TPD4 and KeypadBuilder was to make AMX font installation optional but we did not do that with VisualArchitect because the AMX fonts were necessary. Unfortunately for some users, this became an increasingly frustrating experience when the font installer would lock up. The next releases of VA, TPD4, and KeypadBuilder will include the fix that will resolve the font installer issue. Thank you very much for your patience and support.
    Doug Hall
    AMX Product Management
Sign In or Register to comment.