Home AMX User Forum AMX Design Tools

FTP Dynamic jpg problems

RicardoSiqueiraRicardoSiqueira Junior MemberPosts: 373
I am having a problem with a CV12 and FTP Dynamic .jpg images. Under the TP4(v2.9) Resource Manager I configure the Dynamic Images to pull from the Netlinx Master and it shows correctly under the resource manager and when I assign it to button, but when I load it to the panel or use TP Preview, the image doesn't display. I have also tried Filezilla, and my own remote FTP site and again the image is linked correctly inside 'Resource Manager/Dynamic Images' and it displays correctly when I press 'Get Live File", but again when I loaded it to the panel it disappers. If I use the HTTP approach instead of the FTP under Dymanic Images pulling from aremote site, the jpg shows correctly during TP Preview and after loading the CV12. Any ideas? I need to pull one jpg image from a FTP site or Netlinx Master, but it doesn't work. Weird.... Can I server the image from the Netlinx Master using HTTP? Help???

Comments

  • viningvining X Member Posts: 4,368
  • viningvining X Member Posts: 4,368
    RicardoSiqueira wrote:
    I am having a problem with a CV12 and FTP Dynamic .jpg images.

    Forget the link in my previous post. It's another valid problem but I don't think it's your problem. I just spent the afternoon trying to update radar images that I download to the master and trying to get them refreshed, heck even displayed on a NXD-17VG. Now I've been through this crap many times so I know it should work since I have it working on other TPs. Checked all my TP IP settings, my master permissions and my file paths/names in my resource manager and just like you they refresh and display fine there but not on my TP.

    This made me think it was a permissions thing on the master especially since there are known issues. All be it HTTP not FTP. So I made them the files http w/o user/pass, with user/pass, ftp w/o user/pass, w/ user/path. FTP into the master to verify content and filezilla showed the file names in upper case even though I wrote them to file in lower case so I change file names in the resource manager and downloaded the updated file & downloaded the updated file & downloaded the updated file & downloaded the updated file & downloaded the updated file & again and again remotely from the office and nothing. Not a GD thing worked.

    Finally in frustration Ioaded the file into a MVP5200 onsite and tried that. It worked fine. Well "F" me! The only differnece is one is wireless and the other wired but since the set ups were the same it couldn't be a network thing so I figured "firmware". The last wall mounted TP that was big enough to display radar pics was months ago and probably different firmware. This 17" TP is running the newest firmware for VG panels 2.72.11 so I rolled it back to 2.72.8 and wouldn't ya know it worked fine after that. Go "F" in figure.

    Screwed again and another 6 hours waisted on what is probably a known (but secret) issue.
  • ijedijed Junior Member Posts: 28
    Hi,

    sorry for the necro bump - maybe if this site let you search for threads using 3 characters (silly me why would someone want to search for TLAs like RMF?)

    Anyways 1st time poster, long time lurker etc etc.

    Seems like all the posts I've read of people using FTP for dynamic images have purely been FTPing into a master to grab images stored from there - Is there a problem with getting files from other FTP servers?

    I'm running FileZilla Server on my machine - chuck in the details into TP4 and hit get file and it retrieves the image no problem.

    220-FileZilla Server version 0.9.41 beta
    USER amx
    331 Password required for amx
    PASS *****
    230 Logged on


    Upload it to a panel - problem

    220-FileZilla Server version 0.9.41 beta
    220-written by Tim Kosse ([email protected])
    220 Please visit http://sourceforge.net/projects/filezilla/
    USER amx
    331 Password required for amx

    it never sends the 'PASS xxxxx' and falls over

    exact same thing happens when setting a dynamic image using an RMF command
    if I change protocol to HTTP and grab stuff sitting on my Web server on the same machine it all works fine - just doesn't like FTP...

    Any ideas?
Sign In or Register to comment.