Home AMX User Forum AMXForums Archive Threads AMX Hardware

MVP-7500 doesn't accept download

I have a MVP-7500 that doesn't accept a panel files download anymore. I see it on the network. When I press a button on it Studio sees the action under Studio Notifications, but when I try to download an update TP4 to it I get the folowing error popup in TP4 Design:

"Error performing action get Panel Manifest
Device returned file transfer
NAK code 0x007
Timeout; transfer aborted"

The curious thing is that I can download the same TP4 file to another MVP-7500 without any problems. I do have the latest firmware v2.46.38 on it. It worked for a couple times and just stopped receiving files and gives me the above error message. I have rebooted it many times, removed the batteries, power, etc. Any ideas on how I can fix this problem?




  • Options
    MVP-7500 Download Problem

    Do you have the 'smart transfer' option in TPD4 selected? If so, try downloading the panel using a full/clean download since that creates the manifest file which contains the list of touchpanel files. If this does not work, the current manifest.xma file on the touchpanel may be corrupt and then you will need a new Compact Flash for the MVP-7500. If the full transfer does not work, call AMX Technical Support and see if a new CF is required.

    Since the touchpanel operates on a Linux platform, the compact flash format is not the same you would use under Windows (like a Master compact flash). Consequently, you will need to get a new CF card from AMX if this turns out to be the problem.

    Did you happen to have a transfer that aborted or failed during the initial phase of handshaking with the touchpanel? I have had this happen several times with wireless panels and this is where the CF card becomes corrupted and needs to be replaced. Do you recall what happened the first time the transfer failed?

    Hope this helps.
  • Options
    It may also be an effect with encryption.

    From time to time we have trouble with downloading a TP file if WEP is enabled - sometimes it works, sometimes not - right on the same panel.
  • Options
    DHawthorneDHawthorne Posts: 4,584
    I have had this happen too, and sometimes doing a full download (not necessarily a full clean) instead of a smart download clears it up. Once I had a corrupted manifest and nothing would work, but AMX had a new panel to me the next day.
  • Options
    I haven't had/thought to look, but there's no "zap memory" feature somewhere in the setup pages of these things? Seems bizzare that you have to swap a panel because a file or files are corrupted...

    I've had certain amounts of luck screwing around by putting CF cards from Netlinx masters in my laptop, as long as I don't outright format them. I wonder if the modero CF cards are in a format that Windows would recognize, allowing the possibility of nuking the corrupted files and starting from scratch?

    - Chip
  • Options
    I called AMX tech and they are sending me a compact flash card. They say mine is corrupted. I hope this problem doesn't happen too often, especially with brand new panels like the one I have. The download never happens, it stops at the "Getting Manifest". A clean or normal download yieds same results. Thanks for the responses from all of you!
  • Options
    MVP-7500 Panel Download Issue


    With regards to your question, the Modero panels are embedded Linux based and the CF cards are formatted as one or more Linux file systems. We had a thread going on this topic some time back and the concensus was that while some folks have had good luck with CF cards for Masters, no one really had any good ideas for the Modero panel CFs. AMX has been real good about getting out new CF cards under advanced replacement as needed - a panel exchange is really only necessary if you are not comfortable removing the Modero cover and replacing the CF.

    Ricardo, with regards to your last comment about the frequency of occurrence, I would not say it is a common occurrence. I have a large number of 7500 and 8400 panels and have only run into this problem once. There have been others on the Forums that have also encountered the problem. Clearly, having one file on the touchpanel that if corrupted renders the panel useless is a weak link in the chain but the good news is that it does not happen often. I always make sure that panel downloads (TP4 or firmware) are done with the panel on AC power and in close proximity to an access point to reduce the likelihood of a problem.

  • Options
    jwellsjwells Posts: 25
    We have been having the same problem with downloads to an MVP8400. A full download also came back with the same problem, this happened in Netlinx and TPDesign4.

    I tried downloading a 'full clean transfer' from TPDesign4 using the virtual netlink master and conecting direct to the MVP's USB port. Although this was sucsesful, when I reverted back to trying to download to it over a wireless connection it failed again with the same error. Although all other comms to the panel are working fine.
  • Options
    jeffacojeffaco Posts: 121
    I've found, with my MVP-8400 (since the latest and greatest firmware), that it doesn't work 100% reliably with WEP security enabled.

    Since I have my AP on a separate LAN anyway, and that LAN has about the same security access as outside (Internet) sites have, I decided that I was being overly anal and got rid of WEP. After all, if you manage to break into my AP, all it gets you is access to the Internet, not access to my LAN.

    So, my suggestion: Disable WEP security (if you can without adversely affecting security), and see if that helps.

    If not, then it may very well be a corrupted flash card. If that's the case, when you get a new one, spend 10 minutes copying the image of the CF card prior to inserting it into your MVP. That way, if this happens again, you can recover yourself.

    Here's a link that discusses exactly how to make an image backup of a known-good MVP compact flash card:


    Hope this helps,

    -- Jeff
  • Options
    jwellsjwells Posts: 25
    I tried the download again after disabling WEP and it did work without any problems. I took a look into this further and it seems that on our setup if the MVP8400 panel signal quality is only at 'good' then we needed to disable WEP. However, I played around with the wireless channel numbers and when I changed to channel ?1? the panel gave me a signal strength & quality of 'very good' I then re-enabled the WEP and it continued to work.

  • Options
    The commonly used channels are 1, 6 and 11, to get the most distance in frequency bandwidth.
  • Options
    jwellsjwells Posts: 25
    It was on channel 11. but Channel 1 seemed to give a better responce. Maybe there is some interferance in our area on that band.
  • Options
    DHawthorneDHawthorne Posts: 4,584
    Originally posted by jwells
    It was on channel 11. but Channel 1 seemed to give a better responce. Maybe there is some interferance in our area on that band.
    If I ever run into local interference, it always seems to be on channel 11. My guess is there is a common RF source in that range, or one that produces harmonics on it, because I have seen it quite a lot. I keep telling myself I need a spectrum analyzer, bur I haven't brought myself around to coughing up the $$ for one when switching channels has done the job.
Sign In or Register to comment.