Experience integrating a Nile GXR2 needed..

jisaacjisaac Junior MemberPosts: 34
I am in the process of rolling out a module for the Niles GXR2 multizone reciever & im hitting a major snag here. It seems that some given combination of buttons, conditions-- whatever, causes the RS232 gateway (the outboard box that speaks to the GXR2) to shut down source feedback. As a result, whenever you send a get metadata command:
src,4<cr>
instead of getting:
usc,4,2,11,2,FM,12,4,98.3<cr>
you get:
usc,4,0<cr>

not only that but it seems that any source related functions wont work. The zone functions(volume up, volume down, mute) work, but thats about it.
If you reset the RS232 gateway:
syc,1<cr>
It seems to bring everything back to normal. Sometimes it may take a few tries. This very last time not even the reset worked. i did a rebuild eeprom. I suppose i will now have to use Intellifile to reprogram the RS232 gateway ( im not on site today).

If anyone wrote a module for the GXR2 can you share any notes on this issue? was this even an issue?
I have updated firmware & used 3 different RS232 gateways. Im wondering where i went wrong here.
FYI: i have (1) amfm card, (1)xm card,(1)Im server card, (1) im audio card

Thanks in advance. Niles attitude towards supporting their own protocol is garbage. They will spend more time trying to figure out how *not* to help you--don't even mention that you're writing your own module, they might hang up on you.

Comments

  • DHawthorneDHawthorne Junior Member Posts: 4,584
    jisaac wrote: »
    I am in the process of rolling out a module for the Niles GXR2 multizone reciever & im hitting a major snag here. It seems that some given combination of buttons, conditions-- whatever, causes the RS232 gateway (the outboard box that speaks to the GXR2) to shut down source feedback. As a result, whenever you send a get metadata command:
    src,4<cr>
    instead of getting:
    usc,4,2,11,2,FM,12,4,98.3<cr>
    you get:
    usc,4,0<cr>

    not only that but it seems that any source related functions wont work. The zone functions(volume up, volume down, mute) work, but thats about it.
    If you reset the RS232 gateway:
    syc,1<cr>
    It seems to bring everything back to normal. Sometimes it may take a few tries. This very last time not even the reset worked. i did a rebuild eeprom. I suppose i will now have to use Intellifile to reprogram the RS232 gateway ( im not on site today).

    If anyone wrote a module for the GXR2 can you share any notes on this issue? was this even an issue?
    I have updated firmware & used 3 different RS232 gateways. Im wondering where i went wrong here.
    FYI: i have (1) amfm card, (1)xm card,(1)Im server card, (1) im audio card

    Thanks in advance. Niles attitude towards supporting their own protocol is garbage. They will spend more time trying to figure out how *not* to help you--don't even mention that you're writing your own module, they might hang up on you.

    It's not you, it's Niles.

    Niles has only just fixed the metadata issue (I'm talking in this past week) ... I've been going back and forth with them on it for months. Your RS-232G firmware should be version 2.1.1.1 or higher for it to work properly. I'm not sure if it's in the last full release; I got someone at Niles to e-mail me the bin file just before the latest version of Intellifile came out. It's not just the metadata, though that's most obvious. The problem was that they were not buffering source information. Any time you turned it off or changed zones, the source data was cleared, and since most of the functions are source-context sensitive, they just won't work. It seems to be resolved with the new firmware.
Sign In or Register to comment.