Home AMX User Forum AMX Design Tools

Tp4 Deleting Popups

Anyone else had popups delete from TP4?

I've been working on panel design for the last 40+ hours (almost straight) and once every couple hours when I open a popup I get an error "Can't execute" and then the popup has a red dot on it, if I open it again it will open, but when I close TP4 and reopen the file the popup is gone.

I also just got a "Error creating temp file for transfer" and you CAN'T transfer the file, you have to copy every file into a new TP4 file.


  • Spire_JeffSpire_Jeff Posts: 1,917
    I haven't had this happen, but it almost sounds like maybe a memory space issue on your computer. Have you verified that you have enough harddrive space free to handle the windows temp files, memory swaps, ..... ? Not sure if this helps, but it is something that can be easily overlooked .... especially after 40 hours of designing ;)

  • DHawthorneDHawthorne Posts: 4,584
    Actually, this just happened to me the other day - I suspect a bug in the new release of TPD4.

    I was working on a panel design, and notices one of my popups ceased to pop when I ran it through Panel Preview. I went back to the file, checked the page flips, and they were fine. I tried to open the page in question and got an error message. I tried a few times and got it to open, so I figured it was a glitch, but Panel Preview still wouldn't pop it up. I closed the file and re-opened it, and the popup was gone, not showing in the file at all anymore.

    This is potentially an extremely serious bug. If you don't happen to notice the popup not working, you could load the bad file and not even realize you broke your panel. In my case, it was the video source selection popup, so that would have essentially knocked out the customer's theater if I didn't catch it (and good thing I had a backup too).
  • DHawthorneDHawthorne Posts: 4,584
    By the way, I regularly have 6-8 large panel files open at a time, and have never had difficulty before this past week. At the time I had this problem, I only had 4 panels open, and they were (relatively) small panels. I don't believe it to be a memory or resource issue, though lack of such may aggravate it.
  • GSLogicGSLogic Posts: 562
    Memory is not the issue, I have 25 gigs still open. Also tried deleting... cleaning up regedit... reinstall...

    I have worked with the past releases of TP4 without any problems at all, but now I have that sinking feeling that I could lose popups/files at any time.

    At least I know it's not just me! Thanks
  • trobertstroberts Posts: 228
    I too have a similar problem.

    Occassionally when opening a popup page to modify it. TPD4 gives me an error saying something like, "could not complete requested task" when I try to open it again it seems fine. I will then proceed to make the needed changes to the file, save it and load it. After loading it to my MVP8400 I call the popup, but it does not appear. I look in my file and my popup is still in my file. If I close TPD4 and then open it again that popup page I was just working on is gone. This has happened about 3-5 times in an 8 hour period on two different files.
    The only thing in common with all of my files are that they were originally created in the last build of TPD4.
  • I had this happen with a previous version of TP4, I did a clean install and it fixed it. Haven't experienced anything flaky with the latest version of TP4...yet
  • I know it's probably a stretch in this particular case, but if anyone experiencing the problem can provide any details concerning the popup(s) that "disappeared", it might help in tracking things down. For example, was the popup created from scratch, or copied and pasted from another page? If copied, same panel or different panels? Was it renamed? Did another page with the same name exist in the panel before? Had you successfully saved the panel with the popup in it prior to the problem (verified with a close and re-open of the project)?

    Anything that you can remember regarding the popup in question would definitely help. Thanks.
  • wcravenelwcravenel Posts: 114
    "AMX Engineering

    Registered: Aug 2004
    Location: AMX Headquarters
    Posts: 37
    I know it's probably a stretch in this particular case, but if anyone experiencing the problem can provide any details concerning the popup(s) that "disappeared", it might help in tracking things down. For example, was the popup created from scratch, or copied and pasted from another page? If copied, same panel or different panels? Was it renamed? Did another page with the same name exist in the panel before? Had you successfully saved the panel with the popup in it prior to the problem (verified with a close and re-open of the project)?"

    Now happening to me, after copying all pages over from a problem file in the first place. jparker has original problem file, i think he submitted to engineering to help with TPD crashing problem fix. Page pops up then disappears. Gotta go, need to fix or change to all regular pages?
  • wcravenelwcravenel Posts: 114
    My popups simply time out. time out set to 0. no sound. panel preview works fine.

    Tried changing groups. next is timeout set to long period. then will go to regular pages.
  • DHawthorneDHawthorne Posts: 4,584
    The pages I had vanish from my project have copied and pasted so many time I have no real idea if the one in question was an original, but I rather doubt it. As a matter of fact, the first version was a TPD3 file on a Wave Viewpoint that was imported then dressed up to take advantage of the G4. To fix it, I re-copied the page from an older verion of the same file.
  • trobertstroberts Posts: 228
    My popups also originally came from a TPD3 file. Then converted to TPD4 about 2 revs of TPD4 ago. I take that TPD4 file save it as a different name and then modify. I have been doing this for about a year. I have also copied and pasted some of these existing popup pages and renamed them something else. For example copy existing DSS_POPUP, paste and rename to CBL_POPUP. Hope this helps
  • trobertstroberts Posts: 228
    Any resolution comming on this problem?

    Any resolution comming on this problem? I am still having this problem. I learned to deal with it by having copies of my popups, so if one disappears I dont have to redo the whole page. But that is rather unacceptable. Does anyone know, has any progress been make to fix this problem?
  • GSLogicGSLogic Posts: 562
    I'm sure you don't want to hear this but, the only way I could fix this problem was to open a new TP4 panel... save it, then open the old panel and copy and paste each page and popup to the new panel file.

    I believe this happen when we used a version of TP4 just before the final version came out, which corrupted the file.
  • smithda9smithda9 Posts: 6
    Just to add to the fire, I've also had similar problems with TPD4. One thing I've noticed that hasn't been mentioned is icons in the resource manager dropping out (missing). When looking in RM it says the icon is loading - but never does. If I import the *.png again I get two, the original and a copy. Once I get the icons back/loaded I can transfer the file otherwise I get the can't create temp files error. I hope this helps.
  • tom goeztom goez Posts: 75
    There may be a Tech Note describing this problem. I seem to remember one, but don't have time to go look for it now.

  • trobertstroberts Posts: 228
    I tried...no luck

    I tried what Gary Spaniola suggested and I have had no luck. I created a new TP file. Then I copied in my pages and popups from my problem file and at first I thought it was fine. But after about a day of working with the file. I started having the same problem. I get a could not complete requested task error after trying to open one of my popups in TPD4. I got this error about 4 times throughout the day.
    I am running TPDesign4 Version 2.4 Build 406.

    For those of you who dont know of this problem here is what happens:
    1) Try to open a popup in TPD4
    2) Get an error "could not complete requested task"
    3) If I click save after seeing this error, then close TPD4 and reopen the file the popup that I just tried to open has disappeared from the file. However the popup does open if I click a second time and I can even edit it, but once you click save, the popup will disappear when it is reopened.

    This is getting rather bothersome to say the least.
  • GSLogicGSLogic Posts: 562

    I don't know what to tell you, I haven't had any problems since I copied the corrupted files to a new TP4 file.
  • TPD4 is s**t.

    I keep getting 'Task could not complete' errors.

    then, if i accidently save the file, pages go missing.

    i have to reboot my pc if i get this error, other wise i cant trust tpd4.

    so i waste another 10 minutes reloading OS, tpd4 and the working file.

    this has all started happening since i installed the 'latest' version. (no, i wont mention the version number, i am sick to death of dealing with updates, firmware upgrades and the all round constantly moving goal posts).

    and dont anyone blame my notebook. it's tough, heaps of ram, and fast. it's been doing many other applications without a hitch.

    generally, this makes life as a netlinx programmer hell as it takes twice as long to get anything done, and i have to save the file after every little change as i just dont trust it.

    Totally Pathetic Design 4 is crap.

    in fact, i've just about had enough of dodgy product and tools from AMX, if i get frustrated much more in trying to do my job i think i am going to drop netlinx altogther and get on with something that actually works reliably.
  • oh yeah, i also remember, bitmaps may not display on some pages as well.

    i edit, preview and check a file, it has the bitmaps. but after a download, there is no sign of them on the panel.

    i had to re-edit the file and recreate EVERY instance of the bitmap again before it would work (display).

    more crap
  • jjamesjjames Posts: 2,908
    That was perhaps the nicest & friendliest way to gripe about something. Bravo! Real class right there.

    I had the problem of pop-up pages deleting themselves also, and occasionally do. It's just a random happening, which yes, isn't great . . but you have to deal with it. I realized by throwing my arms up in the air and screaming and yelling does nothing at all to solve the issue. It doesn't seem to happen to everyone, so saying that, I'm sure it's difficult for tech support to recreate the same problem.
  • i dont 'have to deal with it'. amx have to deal with it.

    this is a pivotal tool in my position as a netlinx programmer.

    hey, let's give a carpenter a hammer with a cracked handle.

    i was not given the chance to go 'backwards' in my TPD4 revisions, the new install will disable earlier versions.

    no, 'dealing with it' is just not good enough.

    it just continues to show we are dealing with third rate products that have first class prices.

    and the 'we haven't seen that before' answer is not good enough either. anyone saying that is suggesting i may have done something wrong. when all i do is use the product as expected.

    yeah, i get bullish about it, because no one listens or does anything otherwise.
  • jjamesjjames Posts: 2,908
    Like I said, I've had this problem before. But not anymore. I've unistalled it several times and reinstalled it back again. It works fine of the time for me now. BTW, you do have the latest TPD4 right?

    I've got a question for everyone. Does this only seem to happen on laptops / notebooks? It's only happened to me on my laptop, and never on my desktop. Just curious.
  • curious point about the notebook.. yes it's always on my notebook i have these problems. my desktop is pretty stable, but it doesn't do half the work the notebook has to do.

    the version is 2.4.0 build 406, border version 3.

    okay, i'll try an uninstall/reinstall.

    one other problem by the way. after editing, i'll go to select a controller to upload to, start the transfer, then bang, it all crashes down. if project files haven't been saved they all get lost.
  • jjamesjjames Posts: 2,908
    Try installing the latest, which is TPDesign4 2.5.452 release on 06/21. G4PanelBuilder and G4 PanelPreview updates were also release on that date.

    I'm really starting to wonder if it's notebook. I'd love to hear other people's opinion on if they think it's the notebook or not.
  • DHawthorneDHawthorne Posts: 4,584
    I only had the problem once, and it was with a project that had a lot of cutting and pasting from one file to another. The pages that vanished were pages copied from other files. It seems to be related to references within a page that do not exist in the target project, but I can't be 100% on that - it does hold true for the project I had the problem with.

    And yeah, it was on a notebook. My notebook is my desktop, I just dock it when in the office. It's a full-blown P4 though, with 1G of RAM; I have some difficulty imagining anything particular about laptops that might cause this kind of trouble ... but stranger things have happened.
  • GSLogicGSLogic Posts: 562
    I'm also have the problem of TP4 crashing.

    If I update the dynamic images and then try to upload the file to a panel, TP4 will crash 100% of the time. I have to re-launch TP4 and then upload.
  • jjamesjjames Posts: 2,908
    Yeah, my notebook / laptop is pretty strong too. 1GB RAM, 80GB HD, 3.2Ghz . . . but it's only happening on the laptop. I dunno . . .
  • Reese JacobsReese Jacobs Posts: 347
    Tp4 Deleting Popups

    Here is another data point. I am currently running 2.4.406 - ran 2.3.319 and 2.3.353 both for some time before upgrading to 2.4.406. I run TPD4 on desktops and on multiple laptops. My primary systems are laptops - a lot of memory and fast processors - all systems running Windows XP Professional but all are running Service Pack 1 (no SP2 upgrades).

    I found 2.3.319 and 2.3.353 to be rock solid - the exact opposite of what Richard is experiencing. On 2.4.406, I have encountered a problem similar to that of Gary several times where when I try to connect to the Master to transfer, TPD4 aborts. I then re-start TPD4 and everything is fine. This was not a problem on any of the 2.3 builds. The only problem I ran into on the 2.3 build was that TPD4 was crash if I tried to select and transfer files to multiple TPI panels in the same operation (this was not a problem with MVP panels).

    Anyway, as I said, except for the minor inconvenience noted in 2.4.406, TPD4 has been outstanding. I find it hard to believe the problems can be attributed to laptop versus desktop. It might be the configuration of the laptop contributes to the problem but as I said, I use laptops heavily at home, in the office, and in the field for Studio and TPD4 and I do not have the problems others are noting.

    Anyway, just a data point for what is is worth.

  • i downloaded and installed TPDesign4 2.5.452 release 06/21.

    it crashed at least 6 times on friday when i went to try to connect to a controller or perform an upload. restarting the app would then continue successfully.

    also, sometimes, when trying to edit a button value to move it 10 pixels or so the program would take several seconds to accept the change.

    just reporting the facts...
  • jjamesjjames Posts: 2,908
    Out of curiosity, could you try turning on the diagnostics through Netlinx to see if any errors are being reported when you try to connect? I'm wondering if there's a problem with the programming or master when it's trying to connect or if it's strictly TPD4 software. I'm just trying to think of all the possible reasons why TPD4 crashes.
Sign In or Register to comment.