Serial command pacing

chuckdchuckd Junior MemberPosts: 26
I'm getting some weird stuff while working with my DAS.Tango unit, and I'm fairly sure it has to do with serial command pacing.

Can you hit the Tango with multiple serial commands, one right after the other? If I have to pace the commands, how much time between should I allow? Or am I supposed to look for the proper response before sending the next command (that would be nasty)?

I'm getting a weird situation where I'm getting zones turned on without sending the actual command. Also, the Tango unit does NOT show the blue light for the zone on it's panel front, (so it thinks that zone is off, but it's not). It's a very, very strange situation.

Thanks for any assistance.

Chuck

Comments

  • TurnipTruckTurnipTruck Junior Member Posts: 1,485
    I haven't worked with the Tango yet. However, it's always best to pace your serial commands even if your device says that you don't have to.

    The most common way to do it is with a queue. Create a variable that will serve to hold all of your outgoing commands. Most typically the next command would go out after a response from your serial device from the last command.
    queue="queue,command"
    
  • PhreaKPhreaK Senior Member Posts: 966
    There's a good discussion here on various queuing methods for NetLinx.
  • chuckdchuckd Junior Member Posts: 26
    Thanks for the input. I've implemented a simple queue that buffers up outgoing commands, and sends them if either a serial command has been received, or a .4 second timeout occurs. This of course isn't perfect, since some of the commands take a LONG time to respond (MVER takes about 3 seconds to respond), and the DAS Tango also sends unsolicited serial responses occasionally, I can't really look for a one-to-one method (send a command, wait a resonable time for a response).

    Although this makes things a lot better, I'm actually suspicious of either the 'Disable Room Privacy' command or the 'Disable Paging' command as being the root of my problems. Seems like an AMX bug to me, but after using one or the other of these commands, the first time I select source 2 for zone 12 (and only that combination), all zones 1-8 come on (main DAS unit), but the front panel zone LED's do NOT come on (so, why are the zones playing, you ask?) Good question.......

    I then have to select sources for each of those zones 1-8 and then turn the off again to get them to stop playing. It all seems triggered by one of the two above commands.
Sign In or Register to comment.