Home AMX User Forum Duet/Cafe Duet

Error When Loading Java File


Solved - The two Ni700 processors had Java security manager enabled.

Telnet java sercurity disabled

fixes it

I wonder if anyone could help with this little niggle.

I've been meaning to get my head around Cafe Duet for some time, A while ago I had a play with it, uploaded my own module and also uploaded the Math Test module demo which is located on this forum. Both seemed happy....


I've since had a little time to come back to it, although I've since updated to NS3 and Duet 1.8. Just to refresh me I went back to the step by step and put together a module.

It wouldn't load.

Then I re downloaded Math Test, compiled, packed

It wouldn't load

Not finding the issue, i've upgraded the processor to the latest version. Now in diagnostics I have a little more information.

Line 47 (19:04:23):: Device Access: in /bundle/LETSSEEIFITWORKS_dr1_0_0 match: java.security.AccessControlException: access denied (java.io.FilePermissi
Line 48 (19:04:23):: on /lib/sdkaliases.properties read)
Line 49 (19:04:23):: java.security.AccessControlException: access denied (java.io.FilePermission /lib/sdkaliases.properties read)
Line 50 (19:04:23):: $09at java.security.AccessControlContext.checkPermission(Unknown Source)
Line 51 (19:04:23):: $09at java.security.AccessController.checkPermission(Unknown Source)
Line 52 (19:04:23):: $09at java.lang.SecurityManager.checkPermission(Unknown Source)
Line 53 (19:04:23):: $09at java.lang.SecurityManager.checkRead(Unknown Source)
Line 54 (19:04:23):: $09at java.io.FileInputStream.<init>(Unknown Source)
Line 55 (19:04:23):: $09at java.io.FileInputStream.<init>(Unknown Source)
Line 56 (19:04:24):: $09at com.amx.duet.da.SdkAlias.getAliases(Unknown Source)
Line 57 (19:04:24):: $09at com.amx.duet.da.SdkAlias.getAlias(Unknown Source)
Line 58 (19:04:24):: $09at com.amx.duet.devicesdk.base.ModuleActivator.match(Unknown Source)
Line 59 (19:04:24):: $09at java.lang.Thread.run(Unknown Source)

Any help to the issue would be much appreciated!!



  • Options
    Ok... even more interesting!

    I've just downloaded the ModbusTCP duet example from the forum which has already been compiled into a jar. This, i'd assume worked fine, or there would have been mention of this when it was published.

    This however comes up with the same error as above.

    I can only assume then that the issue is not with duet, rather with the netlinx compiler or it's java interpreter.

    Professionally (not saying that modbus isn't professional) produced modules such as the polycom hdx9004 work absolutely fine although I'm guessing that those may have been digitally signed in some way.

    Any clue?
  • Options
    Even more interesting again!!

    You can scrub the issue about the commercial polycom java working... It's not!! So... That made me think what's going on!??

    I was loading onto a NI700 with .422 firmware so I vpn'd onto my office network to try it on the ni700 on my desk with .414 firmware. Same problem!

    So, in desperation I loaded it onto the office NI3100 with .414 firmware and it worked perfectly. Also my home made java module worked perfectly.

    Just to test I then logged on to a dormant client site and loaded the above - again on a NI3100 but this time with .422 firmware. Worked perfectly again. (then i put it back as it was! so they'll never know!)

    Any ideas what could be going on. I completely threw myself at the beginning thinking it was a java issue but now it appears to be a problem with the intepreter which is on the NI700 unit.
Sign In or Register to comment.