Home NetLinx Modules & Duet Modules

Duet and RS232 Control of Marantz SR8500 Receiver

I hope this message is in the right place.
I'm still very new to programming AMX and I'm hoping for some expert advice.

I'm trying to program a Netlinx NI-3000 controller to work with a Marantz SR8500 Receiver.

I've downloaded the duet module provided by AMX for the Marantz SR8500 Receiver and while I've been able to get the virtual device to recognize when I send it a command in Netlinx Studio and have it send feedback, I'm not able to get the receiver to actually do anything, like, turn on!

To clarify what I mean a little bit: if I, for example, send the pulse channel 9 command to the virtual device (41001:1:1) it correctly sends the command string "@PWR:0$0D" to the actual device at 5001:1:1, it just doesn't actually toggle the power to the receiver

Now, I know that the receiver must be in standard and not economy mode for it to accept serial commands when it's powered off, which it is. I know the cable I'm using is good because I made it about 3 hours ago. It only has pins 2, 3 and 5 wired and I used a tester to confirm that pins 2, 3 and 5 were all in good working order.

Some strange behavior I noticed in the Notifications window in Netlinx Studio is that the Duet Module appears to be sending the same four commands over and over and over again, about every 5 to 10 seconds

"Command to [5001:1:1] - [SET BAUD 9600,N,8,1 485 DISABLE]
Command to [5001:1:1] - [HSOFF]
Command to [5001:1:1] - [XOFF]
String To [5001:1:1]-[@PWR:?$0D]"

and it repeats.

So my first question is: can anyone out there think of something right away that I'm messing up? and secondly, could the repetition of these commands be an indicator that something isn't right? I can understand the last command repeating over and over again, polling the receiver about it's current power status, but I have a feeling that someone who knows what they're talking about is going to tell me that none of these should be repeating and they only are because the NI-3000 is having connection issues with the Receiver.

Sorry if this is rambling, I've been staring at a computer screen for several hours now going in circles!

Any help is greatly appreciated

Comments

  • viningvining X Member Posts: 4,358
    Is the TX light blinking for that dev port on the NI when a command is being sent? If so maybe try reversing pins 2 & 3 on one end of the cable.

    Commands repeating could be normal depending on how that module was written. Just trying to establish comms and maintain it I would presume.
  • DHawthorneDHawthorne Junior Member Posts: 4,584
    Marantz RS-232 wiring is backwards. Everyone else in the industry using a female-female cable reverses pins 2&3 to make it a crossover. Marantz receivers (everything Marantz, except the BluRays, which are really Denons) are straight through. So check that first. I keep a null adapter in my computer bag just to do quick checks like that.

    The second thing I've noticed about Marantz RS-232 is they sometimes shut down the RS-232 port. THe most common reason is power saving mode. If power saving is turned on, the port will be dead when the receiver is off, so you can't turn it on by RS-232 until you disable the power saving. The other reason the ports shut down I haven't been able to quick get a handle on; but if you power cycle the receiver (cold boot: not just standby, but actually unplug the thing), it comes back and generally stays back. It's not real common (unlike Meridian and McIntosh, where it happens all the time), but it happens.
  • glr-ftiglr-fti Junior Member Posts: 286
    I've had the same problem Dave describes and now put all Marantz equipment on a PC1 and then have the capability to shut the unit off and then back on. I also do it at startup just to know I am starting out with it receiving.

    I have also had problems with Marantz equipment on Port 1 for whatever reason. If I move it off to another port everything works fine.
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    Marantz has added their new 'environmentally friendly "Feature" ' that is annoying as heck.

    Out of the box, the unit is really OFF when it's off. It will accept no commands as the power to the unit is dead. In order to set the unit into 'non-environmentally friendly ' mode and therefore leave the unit in standby, you have to send it the commands to do so. Those commands differ from unit to unit depending upon what you have.

    What's even more annoying is if the unit sits without power for any length of time (power outage, home owner leaves the home for long time) the units default back to factory and you need to turn on the front panel button manually.

    I typically end up sending the command(s) for non-environmentally friendly mode both at power up and then at power down. The client has to remember to push the power button if the device fails to respond before calling us.

    In addition to all this, I"ve seen some of their newer recievers come out of the box unresponsive. However, one you send the command to change the feedback mode to whatever, it starts chatting like crazy.
  • mvhuffordmvhufford Junior Member Posts: 3
    Hi Guys,
    wow, thanks for all of your quick responses!

    As far as Marantz trying to be environmentally friendly, I have made sure that the receiver is in the standard, and not economy mode in the settings menu. Are you saying that in addition to changing the setting in the menu, the program should send a serial command to ensure that it does not go into power saving mode? Man, if that's the case, Marantz really wants to save a few watts!

    When I made the cable last night, I followed the wiring diagram included with the duet module documentation, which was 2-2, 3-3, 5-5, so I don't think that's the problem.

    I've uploaded the sample file included with the duet module to the netlinx, so the code on the system is as straightforward and simple as possible and I'm still having no luck. I tried swapping ports and changing the address of the receiver from 5001:1:1 to 5001:4:1, but when I uploaded the new program to the netlinx, it still thought the receiver was at 5001:1:1? ? ? Maybe I'm doing something with the uploading?
  • ericmedleyericmedley Senior Member - 4000+ posts Posts: 4,177
    mvhufford wrote: »
    Hi Guys,
    wow, thanks for all of your quick responses!

    As far as Marantz trying to be environmentally friendly, I have made sure that the receiver is in the standard, and not economy mode in the settings menu. Are you saying that in addition to changing the setting in the menu, the program should send a serial command to ensure that it does not go into power saving mode? Man, if that's the case, Marantz really wants to save a few watts!

    Yes, that has been my experience. Besides, it doesn't really hurt to send the command anyway...
  • mvhuffordmvhufford Junior Member Posts: 3
    I couldn't find any information about the serial command to take the unit out of power save mode.

    Should I be looking in the documentation that lists the rs-232 commands?

    Thanks for all of your help!
  • SamkAMXSamkAMX Junior Member Posts: 29
    if youre new at programming i would try this. hook up your seriasl cable directly to marantz and send this command "'@VOL:1',13" via hyper terminal (volume)

    make sure receiver is on
    try using null modem adapter if it doesnt work

    when you get that working, then hook up receiver to amx and try sending same code via "control a device"
  • Dwatson8791Dwatson8791 Junior Member Posts: 9
    Same issues

    I am hooking to a Denon DN-A7100, which is just a rebranded Marantz. I have set the Standby setting to Normal, tried using a null modem, verified communication settings, still no luck. Not even getting any feedback when I manually turn the dials.

    I looked through the documentation and did not see anything that was related to a serial command to turn the economy settings off. If anyone knows this code, could you please post it? Thanks.
Sign In or Register to comment.