Home AMX General Discussion

IRIS and XP

tom goeztom goez Junior MemberPosts: 75
When using my IRIS, occasionally it will page fault and bomb out of the program. The error window shows:

IREdit.exe - Common Language Runtime Debugging Services
Application has generated an exception that could not be handled.
Process id=0x330 (816), Thread id=0x84c (2124)

Sometimes it locks up the laptop, sometimes not. I have disabled the network, and shut down Norton Anti-virus which makes it happen less often.

Any ideas? For what the IRIS costs, it should work flawlessly.

Tom Goez

Comments

  • Reese JacobsReese Jacobs Junior Member Posts: 344
    IRIS and XP

    Tom,

    I have used the IRIS extensively on XP but almost exclusively with Netlinx Studio 1.2 for creating IR files and not with IREdit. I have never had any problems with the IRIS or Studio 1.2 capturing, emitting, or editing IR files. I suspect that your problem is more likely to be with IREdit and not with the IRIS per se. Others in the forum that use IREdit with IRIS might be able to shed some light. I find IREdit a bit tedious for what I need to accomplish with IR files so I have stayed with Studio 1.2.
  • Spire_JeffSpire_Jeff Formerly Caffeinated Programmer Posts: 1,917
    I haven't done extensive work with the IRIS, but I have had to learn in a few remotes. I do use IREdit and I have not had any problems. I haven't tried it on my new laptop, but the previous laptop was running XP SP1... if that helps at all.

    Jeff
  • mediapilotincmediapilotinc Junior Member Posts: 82
    I have used my Iris and IREdit on XP-Pro SP2 without any issues (as long as I do not have any other programs looking for the RS232 port).
    Tom; Does your Iris/IREdit have the same issue on other PCs? If you see problems on other machines, you may have a bad IRIS. If it works on other machines I would try and re-install IREdit. A call to Tech Support would follow if this still does not resolve the issue.
  • tom goeztom goez Junior Member Posts: 75
    IRIS and XP

    Thanks Reese for the input.

    Well, I can't remember the last time I used Studio 1.2 !!

    I am using version 2.3 now, but it doesn't have a link to IREdit.

    Versions 2.0 & 2.1 (as I remember) just linked to IREdit.

    I'll call tech support and see what I can find out.

    Tom
  • tom goeztom goez Junior Member Posts: 75
    IRIS and XP

    Thanks Jeff and Wilbert,

    This is our second IRIS (a newer one with less parts inside). Being one of AMX's first programmers (back in the days of eproms - 1982), I have captured lots of IR files over the years. Seems this problem started showing up under XP and maybe 2000, but I just can't remember.

    In the past decade, IR files don't need to be captured as much because most the devices we use are serial control or IP control.

    This problem shows up on multiple laptops, but is very hit and miss. The IRIS works up to the point where it bombs out the operating system. Sometimes stopping a process with cntl/alt/del lets you reload IREdit, sometimes not. All computers are running XP Pro with SP2.

    The IRIS does make workable files. After bombing, you can reload IREdit and continue on until you are finished. Sometimes, you can complete a hand control without problems.

    I will try the IRIS on a desktop computer here when I get a little time. As for now, I have more important things to do!

    There is a car show at 4:00 PM and I have to get the car ready.

    Thanks to all who responded.

    Tom Goez
    ACE Programmer
    ACE Installer
  • DHawthorneDHawthorne Junior Member Posts: 4,584
    Being a serial device, I can't imagine this is being caused by the IRIS. It's far more likely a serial port problem or driver issue, or an issue with whatever program you are using for the capture (IREdit or Studio). Whatever kind of junk that gets fed to through the serial port should have no bearing on the computer operation unless the port or the application sends it to the wrong place.

    I have never had a problem with an IRIS crashing any computer I have used. I generally use IREdit. Now, I've scrambled the IRIS itself with a bad send (continuously blinking [] that requires a power down to clear), but that is another story. My current machine doesn't evne have a serial port - I have to use a USB-serial adapter. That thing causes a BSOD sometimes with other applications if I run it at too high a baud rate, but never with the IRIS.
Sign In or Register to comment.